Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Strange output drops on 3120 cisco HP blade

Hi,

I've a strange command output on a catalyst blade HP 3120 about the output drops.

When I issue the command show interface I see the following:

SWNCL6#sh int g2/0/2

GigabitEthernet2/0/2 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 58bf.ea80.1882 (bia 58bf.ea80.1882)

  Description: ESX4-01

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:02, output hang never

  Last clearing of "show interface" counters 5d13h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3499518407

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 118000 bits/sec, 118 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     53447323 packets output, 6453499563 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

If I immediately repeat the command after 1 second I see another value:

SWENCL6#

SWENCL6#

SWENCL6#

SWENCL6#

SWENCL6#sh int g2/0/2

GigabitEthernet2/0/2 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 58bf.ea80.1882 (bia 58bf.ea80.1882)

  Description: ESX4-01

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:03, output hang never

  Last clearing of "show interface" counters 5d13h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 37576

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 118000 bits/sec, 118 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     53447323 packets output, 6453499563 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

This happens all the times I give the command. The interface connects the blade to the core switch (Catalyst 6509) and the running IOS is the following:

WS-CBS3120X-S      12.2(58)SE1           CBS31X0-UNIVERSALK9-M

I think the possible cause could be a bug on the version but I didn't find anything on cisco website and the release 12.2(58)SE1 sems to be the last one for that hardware.

Anyone have suggestions?

Thanks

Fabio

4 REPLIES
VIP Super Bronze

Strange output drops on 3120 cisco HP blade

Hi,

Usually, output drops are not an IOS bugs/issues.

have a look at this link for some troubleshooting tips.

http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080094791.shtml#topic4

HTH

New Member

Strange output drops on 3120 cisco HP blade

I give the command:

show int g2/0/2

and I have the following value about the total output drops

Total output drops: 3499518407

I repeat the command after 3 seconds:

Total output drops: 37576

If I had a problems on the interface I should see the first value increased, that's why I was thinking about a IOS bug

Regards,

Hall of Fame Super Gold

Strange output drops on 3120 cisco HP blade

12.2(58)SE1

Could be an IOS bug because this version is very buggy.

If you can, use 12.2(55)SE8 and observe.

Cisco Employee

Strange output drops on 3120 cisco HP blade

Hi, this is probably late, but the software counters for output drops on these types of switches (3750's, blade switches) are not reliable.

What you need to check is "show platform port-asic statistics drop" for a reliable drop counter on an interface. This will give you the hardware counters

https://tools.cisco.com/bugsearch/bug/CSCtq86186/?reffering_site=dumpcr

Switch stack shows incorrect values for output drops/discards

on show interfaces. For e.g.,

--- show interfaces ---

GigabitEthernet2/0/5 is up, line protocol is up (connected)

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 4294967163

Conditions:

This is seen on Stackable switches running 12.2(58)SE or later.

Workaround:

None.

418
Views
0
Helpful
4
Replies