Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Sub internface shutdown in Frame Relay point to point in GNS3

Hello

Please take a look on GNS3 file in attached, I'm sure already configured both routers s1/0 is no shut, but still status down, please help.

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Sub internface shutdown in Frame Relay point to point in GNS

Hi,

of course GNS3 supports it(but only on routers  which do Frame-relay switching) but these are your 2 DTE devices, no ? so they should be intf-type DTE and the switch where they are connected should be DCE(which is default for built-in GNS3 FR switch.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
19 REPLIES
Purple

Sub internface shutdown in Frame Relay point to point in GNS3

Hi,

post your configs and  sh ip int br

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Community Member

Sub internface shutdown in Frame Relay point to point in GNS3

R3:

R3#show run
Building configuration...

Current configuration : 1261 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no fair-queue
frame-relay intf-type nni
!
interface Serial1/0.1 point-to-point
ip address 192.168.0.1 255.255.255.0
frame-relay interface-dlci 241
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

R3#show ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES NVRAM  administratively down down

FastEthernet0/1            unassigned      YES NVRAM  administratively down down

Serial1/0                  unassigned      YES NVRAM  up                    down

Serial1/0.1                192.168.0.1     YES NVRAM  down                  down

Serial1/1                  unassigned      YES NVRAM  administratively down down

Serial1/2                  unassigned      YES NVRAM  administratively down down

Serial1/3                  unassigned      YES NVRAM  administratively down down

R4:

R4#sh run
Building configuration...

Current configuration : 1251 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no fair-queue
frame-relay intf-type nni
!
interface Serial1/0.1 point-to-point
ip address 192.168.0.2 255.255.255.0
frame-relay interface-dlci 240
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

R4#sh ip int br

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES NVRAM  administratively down down

FastEthernet0/1            unassigned      YES NVRAM  up                    up

Serial1/0                  unassigned      YES NVRAM  up                    down

Serial1/0.1                192.168.0.2     YES NVRAM  down                  down

Serial1/1                  unassigned      YES NVRAM  administratively down down

Serial1/2                  unassigned      YES NVRAM  administratively down down

Serial1/3                  unassigned      YES NVRAM  administratively down down

Purple

Sub internface shutdown in Frame Relay point to point in GNS3

Hi,

on both serial interfaces :

no frame-relay intf-type nni

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Community Member

Sub internface shutdown in Frame Relay point to point in GNS3

Hi cadet alain

This lab is following our real environment, is GNS3 don't support frame-relay intf-type nni ?

Thanks

Purple

Re: Sub internface shutdown in Frame Relay point to point in GNS

Hi,

of course GNS3 supports it(but only on routers  which do Frame-relay switching) but these are your 2 DTE devices, no ? so they should be intf-type DTE and the switch where they are connected should be DCE(which is default for built-in GNS3 FR switch.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Community Member

Re: Sub internface shutdown in Frame Relay point to point in GNS

Sorry, I don't understand, can you tell me how to do that ?

Community Member

Re: Sub internface shutdown in Frame Relay point to point in GNS

Completed with frame-relay intf-type dte on both router.

Thanks

Community Member

Re: Sub internface shutdown in Frame Relay point to point in GNS

Hi Cadet alain,

Now I want to create sub-interface in s1/0, it allow me to create s1/0.1, but can't create s1/0.2, it showing "Incomplete Command", is it GNS3 bug ?

Thanks

Re: Sub internface shutdown in Frame Relay point to point in GNS

Hello,

I think you might need to specify the type of sub interface it is after int s1/0.2 - Now, depending on your topology it could be either options.

Same as what you have done for your first sub-if. Example below of the options...

Rack1R1(config)#int s0/0/0.1

% Incomplete command.

Rack1R1(config)#int s0/0/0.1 ?

  multipoint      Treat as a multipoint link

  point-to-point  Treat as a point-to-point link

hth.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
Community Member

Re: Sub internface shutdown in Frame Relay point to point in GNS

Hi

You right, I forgot use the point to point command.

Now I have another problem, after I created s1/0.2 interface with ip address in both routers, I can ping each others with this subinterface ip address, but s1/0.1 can ping.

Please take a look in attached GNS3 file.

Thanks !

Re: Sub internface shutdown in Frame Relay point to point in GNS

Hello, I was able to open the file, I saw R3 and R4 connected to a frame-relay switch, however there were no configs on the routers. Could you please post'em up here?

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
Community Member

Re: Sub internface shutdown in Frame Relay point to point in GNS

R3#show run
Building configuration...

Current configuration : 1469 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no fair-queue
!
interface Serial1/0.1 point-to-point
ip address 172.16.228.21 255.255.255.252
frame-relay interface-dlci 241
!
interface Serial1/0.2 point-to-point
ip address 172.17.228.21 255.255.255.252
frame-relay interface-dlci 341
!
interface Serial1/0.3 point-to-point
ip address 10.10.228.21 255.255.255.252
frame-relay interface-dlci 441
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

------------------------------------------------------------

R4#show run
Building configuration...

Current configuration : 1459 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no fair-queue
!
interface Serial1/0.1 point-to-point
ip address 172.16.228.22 255.255.255.252
frame-relay interface-dlci 240
!
interface Serial1/0.2 point-to-point
ip address 172.17.228.22 255.255.255.252
frame-relay interface-dlci 340
!
interface Serial1/0.3 point-to-point
ip address 10.10.228.22 255.255.255.252
frame-relay interface-dlci 440
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

Re: Sub internface shutdown in Frame Relay point to point in GNS

Have you checked your frame-relay mapping on the frame-relay cloud is correct?

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
Purple

Sub internface shutdown in Frame Relay point to point in GNS3

Hi,

interface Serial1/0.2 point-to-point

ip address 172.17.228.21 255.255.255.252

frame-relay interface-dlci 341

!

interface Serial1/0.3 point-to-point

ip address 10.10.228.21 255.255.255.252

frame-relay interface-dlci 441

None of these DLCIs exist on CU and the same for DLCIs 340 and 440 on R4

Also you can get rid of the frame-relay switching command on both routers as they are FR DTE devices so they don't need to switch.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
684
Views
0
Helpful
19
Replies
CreatePlease to create content