Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SubInerfaces Catalyst 3750-E

Hello.

I'm looking for information about if the 3750 Platform supports sub-interfaces.

Something like:

GigabitEthernet0/1.2

Thanks.

7 REPLIES
Hall of Fame Super Silver

Re: SubInerfaces Catalyst 3750-E

Dywer

I do not believe that the 3750 supports subinterfaces. Subinterfaces like that are frequently associated with trunk interfaces. But the 3750 configures trunking on physical interfaces not subinterfaces. What are you wanting to do with subinterfaces on the 3750? If we knew what you are trying to accomplish then perhaps we could suggest alternatives that would work.

HTH

Rick

New Member

Re: SubInerfaces Catalyst 3750-E

I have an old 4908 switch. Each physical interface has 3 sub-interfaces like:

interface GigabitEthernet2.10

description data 10

encapsulation dot1Q 10

no ip directed-broadcast

bridge-group 10

!

interface GigabitEthernet2.11

description voice 11

encapsulation dot1Q 11

no ip directed-broadcast

bridge-group 11

!

interface GigabitEthernet2.99

description management

encapsulation dot1Q 99

no ip directed-broadcast

bridge-group 99

!

And there is a BVI to route the information.

I'm trying to do the same with 3750 switch.

Hall of Fame Super Silver

Re: SubInerfaces Catalyst 3750-E

Dywer

I do not believe that you can do literally the same thing on the 3750. I believe that you can achieve the same result but the way to do it is different. On the 3750 configure an interface as a trunk, configure VLANs 10, 11, and 99, and make sure that these VLANs are included on the trunk.

HTH

Rick

New Member

Re: SubInerfaces Catalyst 3750-E

The equivalent configuration for 3750s would be something like:

vlan 10

description Data 10

vlan 11

description Voice 11

vlan 99

description Management

interface Vlan 10

description Data 10

interface Vlan 11

description Voice 11

interface Vlan 99

description Management

interface GigabitEthernet2/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,11,99

switchport mode trunk

New Member

Re: SubInerfaces Catalyst 3750-E

Thanks for your help.

Another question.

How do I configure diffent interfaces in the same bridge-group ? and How do can be controlled the traffic among the Vlans when and SVIs interfaces ?

Hall of Fame Super Bronze

Re: SubInerfaces Catalyst 3750-E

First, you create a Layer2 Vlan:

switch(config)#vlan 2 name test

Second, you assign ports to this Vlan:

switch(config)#interface fx/x

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 2

Optional, you enable routing for that Vlan

switch(config)#interface Vlan 2

switch(config)#ip add x.x.x.x y.y.y.y

I highly recommend reading this document:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_40_se/configuration/guide/swvlan.html

HTH,

__

Edison.

New Member

Re: SubInerfaces Catalyst 3750-E

Thanks for help.

I'm asking all those question because I would like to have the Inside, DMZ and Campus Network in the same switch stack.

How can I isolate the DMZ from the others subnets?

Thanks.

150
Views
10
Helpful
7
Replies