Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

summary route in ripv2

Hi every body!

when i configure the summary route on a router running eigrp, the route appears in routing table as:

D 172.172.0.0 255.255.0 summary address null0.

But when i configure summary route on a router running ripv2, it does not appear so in routing table. Is it normal behavior or it has to do something with my old ios?

thanks a lot!

4 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: summary route in ripv2

Hello Sarah,

in this case we need to compare info in command reference

https://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_rip.html#wp1012075

https://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1013188

nothing explicit here.

To be noted that the route to null0 is a routing loop avoidance mechanism should the packet come back to this router and no specific component route exists for it the local node can silently discard it.

I mean EIGRP has this feature for loop avoidance. (also OSPF has a similar concept in the discard route)

RIP probably doesn't implement this protection but you could use it configuring a manual floating static route to null0

ip route 172.172.0.0 255.255.0 null0 220

the last 220 is the AD

Hope to help

Giuseppe

Hall of Fame Super Bronze

Re: summary route in ripv2

Sarah,

The null0 implemented within EIGRP during a summarization is called a discard route.

EIGRP allows you to summarize networks that it does not have a route for. For instance, you can send a 0.0.0.0 0.0.0.0 with EIGRP while you can't do this with RIP.

With RIP, in order to summarize a network, the network must be in the RIP database, as soon as the network disappears from the database, the summary will be gone as well - hence there isn't a need for a discard route (null0).

HTH,

__

Edison.

Hall of Fame Super Bronze

Re: summary route in ripv2

Sarah,

A longer prefix is there and that's the one you are summarizing.

Try summarizing 170.170.0.0 255.255.0.0 with your current config.

__

Edison.

Hall of Fame Super Bronze

Re: summary route in ripv2

Correct, thus you don't need a discard route (null0) implemented by the routing protocol as the summary checks for the network to be in the routing table.

__

Edison.

11 REPLIES
Hall of Fame Super Silver

Re: summary route in ripv2

Hello Sarah,

in this case we need to compare info in command reference

https://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_rip.html#wp1012075

https://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1013188

nothing explicit here.

To be noted that the route to null0 is a routing loop avoidance mechanism should the packet come back to this router and no specific component route exists for it the local node can silently discard it.

I mean EIGRP has this feature for loop avoidance. (also OSPF has a similar concept in the discard route)

RIP probably doesn't implement this protection but you could use it configuring a manual floating static route to null0

ip route 172.172.0.0 255.255.0 null0 220

the last 220 is the AD

Hope to help

Giuseppe

Hall of Fame Super Bronze

Re: summary route in ripv2

Sarah,

The null0 implemented within EIGRP during a summarization is called a discard route.

EIGRP allows you to summarize networks that it does not have a route for. For instance, you can send a 0.0.0.0 0.0.0.0 with EIGRP while you can't do this with RIP.

With RIP, in order to summarize a network, the network must be in the RIP database, as soon as the network disappears from the database, the summary will be gone as well - hence there isn't a need for a discard route (null0).

HTH,

__

Edison.

Bronze

Re: summary route in ripv2

Hi Edison !

you suggested that summary route must be present before router can announce it .

In my lab i found this was not the case.

ra s0-------------------s0 rb

ra config: ( output omitted)

version 12.1

interface Loopback1

ip address 172.172.1.1 255.255.255.0user static route, o - ODR

!

interface Loopback2

interface Serial0

ip address 202.202.202.1 255.255.255.0

ip summary-address rip 172.172.0.0 255.255.0.0

clockrate 56000

!

interface Serial1

ip address 200.200.200.1 255.255.255.0

clockrate 56000

!

router rip

version 2

network 172.172.0.0

network 202.202.202.0

no auto-summary

!

=====================================

rb config:( output omitted)

version 11.2

!

interface Serial0

ip address 202.202.202.2 255.255.255.0

!

interface Serial1

ip address 201.201.201.2 255.255.255.0

clockrate 56000

!

router rip

version 2

network 202.202.202.0

!

==================

routing table at rb:

routerB#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

R 172.172.0.0/16 [120/1] via 202.202.202.1, 00:00:01, Serial0

C 202.202.202.0/24 is directly connected, Serial0

===========================

Is it a bug again?

thanks a lot!

Hall of Fame Super Bronze

Re: summary route in ripv2

Sarah,

A longer prefix is there and that's the one you are summarizing.

Try summarizing 170.170.0.0 255.255.0.0 with your current config.

__

Edison.

Bronze

Re: summary route in ripv2

hi Edison!

just want to confirm following;

rb is able to advertise summary route 172.172.0.0/16 to ra because its subnets are present in rb routing table.?

you suggested try 170.170.0.0/16

But it won't be advertised because just using the command ip summary-address rip 170.170.0.0 255.255.0.0 is not enough. The subnet of this class B network must be present in routing table and also " router rip

network 170.170.0.0 is needed.

am i correct?

thanks a lot!

Hall of Fame Super Bronze

Re: summary route in ripv2

Correct, thus you don't need a discard route (null0) implemented by the routing protocol as the summary checks for the network to be in the routing table.

__

Edison.

Super Bronze

Re: summary route in ripv2

I recall, from some RIPv2 testing, an explicit summary requires an active (i.e. would be in the route table) subnet for the summary to appear in the route table. (When the summary appears in the route table, its subnets do not.)

[edit]

Didn't see Edison's post until I posted mine.

PS:

re: "For instance, you can send a 0.0.0.0 0.0.0.0 with EIGRP while you can't do this with RIP. "

Recall for the Cisco RIPv2 I was testing, a default-originate was supported which did seem to advertize the default route.

Hall of Fame Super Bronze

Re: summary route in ripv2

Recall for the Cisco RIPv2 I was testing, a default-originate was supported which did seem to advertize the default route.

Yes, but that's not a summary.

__

Edison.

Super Bronze

Re: summary route in ripv2

Agreed, but when you wrote "EIGRP allows you to summarize networks that it does not have a route for. For instance, you can send a 0.0.0.0 0.0.0.0 with EIGRP while you can't do this with RIP. "; the second sentence could also be read(?) as it's not possible to send (specifically) 0.0.0.0 0.0.0.0 with RIP. However, I now know you only meant it as an example for sending a summary. Perhaps others might misread it too. (Also, I'm not sure about RIP and default-originate, which is why I mentioned RIPv2.)

Hall of Fame Super Bronze

Re: summary route in ripv2

Joseph,

The whole thread is about summarization, not the advertisement of Quad 0.

I can't cover every single angle to avoid confusion, if someone is confused (like you) feel free to raise the question.

Yes, you can send a Quad 0 in RIP with default information-originate but this is not a summary generated Quad 0 and this is what the thread is about.

I've covered this already but I'll repeat it just for you:

http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/irp_cfg_info_prot_ps6350_TSD_Products_Configuration_Guide_Chapter.html

Cisco IOS software will source the default network with RIP if one of the following conditions is met:

•The ip default-network command is configured.

•The default-information originate command is configured.

•The default route is learned via another routing protocol or static route and then redistributed into RIP.

There is another variant that I discovered today by chance. A static default route pointing to an interface along with network 0.0.0.0 under RIP will also generate a default route.

__

Edison.

Super Bronze

Re: summary route in ripv2

Edison, it's true I quoted one of your statements, and provided an example, where that statement (NB: alone and out of context) would be incorrect.

You replied to my post noting the context was as a summary address. This reply was good in that in clarified the meaning, since as your latest post notes, you can't cover every angle. (Difficult for anyone to accomplish.)

Upon reflection, I'm wondering whether you took my statement as somehow discounting your expertise or some type of personal affront. Since, I can see how one way of reading my post would be saying what you posted was mistaken (which it was if taken at face value), yet it's certainly not in the context you intended.

I think I understand your point about raising a question, and will try to be more tactful when something might be incorrect (also avoid rushing edits).

Likewise, perhaps, you might want to carefully re-read your latest post, and consider how it is worded. My post was strictly targeted at one statement and how it (again alone) would be incorrect. In no way was there any negative meant against you, because even if you did make a mistake, assuming you sometimes do make mistakes(?), I believe in correcting mistakes and moving on. (BTW, I'm not keeping score.)

Your lastest post, though, does come across a bit as personal attack directed toward me with things like "someone is confused (like you)", when I never said I was confused, or "I've covered this already but I'll repeat it just for you:".

I'm hoping a personal attack was not intended, and if not, we both need to work on our writing technique.

If a personal attack was intended, well not much I can do, beyond reminding you of your former promise "Ok, I won't disagree with any of your posts in the future... " (and hope you have a sense of humor).

519
Views
0
Helpful
11
Replies