Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SUP II Intervlan

Hi Friends,

I have one Catalyst 4503 chassis with SUP-II + TS supervisor Engine.

IOS version is Cat4000-I9K91S-M 12.2(25) EWA7. I have go through the documents of Intervlan setup, but I can't to it.

PC1  <----------------------SUP-II + TS --------------------> PC2

192.168.10.25     gig2/10         gig2/17           192.168.20.24

I can ping from PC1 to Sup and simultaneuosly PC2 to sup.

I can ping 192.168.10.X and 192.168.20.X series within the Supervisor engine.

I can't ping from PC1 to PC2.

I enabled IP routing command, but it is not shown in the running configuration.

Please check this configuration:

Building configuration...

Current configuration : 3157 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$dAhP$PiVa.eEY4hvLWiRF1rGBg.
!
no aaa new-model
qos
cef table consistency-check IPv4 data-checking
vtp domain test-domain
vtp mode transparent
ip subnet-zero
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!

vlan internal allocation policy ascending
!
vlan 3
name test
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2

!

----output cut------

!
interface GigabitEthernet2/8
!
interface GigabitEthernet2/9
!
interface GigabitEthernet2/10

switchport mode access
!
interface GigabitEthernet2/11
!
interface GigabitEthernet2/16
!
interface GigabitEthernet2/17
switchport access vlan 3
switchport mode access

!
interface GigabitEthernet2/18
!
interface GigabitEthernet2/19
switchport mode access
!

---Output cut----

!
interface GigabitEthernet2/48
!
interface Vlan1
ip address 192.168.10.41 255.255.255.0
!
interface Vlan2
ip address 192.168.11.1 255.255.255.0
--More--
shutdown
!
interface Vlan3
ip address 192.168.12.1 255.255.255.0
!
ip http server
!
line con 0
stopbits 1
line vty 0 4
password 7 0207005602085E731F
login
line vty 5 15
password 7 11081D081E1C5A5E57
login
!
!
end

Switch#

Please send a valuable solution for this issue.

Thanks in advance.

Thanks & Regards,

Saravanan.

11 REPLIES

Re: SUP II Intervlan

Hi,

From your config PC1 is in VLAN1 and PC2 is in VLAN3.

The IP address applied to your switch VLAN3 interface is 192.168.12.1 /24 but that allocated to PC2 is 192.168.20.24 /24 - these are in different subnets

Two solutions are possible:

  1. Change the IP address of PC2 to 192.168.12.24
  2. Change the IP address of switch VLAN3 to 192.168.20.1

Hope this helps

New Member

Re: SUP II Intervlan

Hi James,

Thanks for your reply,

Sorry, I gave the ipaddress in the diagram is wrong. Please check this below diagram.

PC1  <----------------------SUP-II + TS --------------------> PC2

192.168.10.25     gig2/10         gig2/17           192.168.12.24.

I gave the right IP address in the supervisor.

Regards,

Saravanan.

Purple

Re: SUP II Intervlan

  Check to make sure the default gateways on the pc nic are pointing to the correct address on the 4500 .  Also verify all PC firewalls are turned off before you try the test .  On your one SVI for vlan 1 you have the address as .41 is that correct seeing that the other 2 are .1 ?  Are the pc nics for vlan 1 pointing to the .41  ?

New Member

Re: SUP II Intervlan

Hi glen,

I checked the default gateway of the both PCs which is given in the vlan address of the switch.

I can ping to Switch, but one pc to another pc ping is not happen (inter vlan).

I enabled the IP routing command, but it is not shown in the running configuration.

Please the IOS version, Is it ok to configure Inter vlan or not.

Thanks in advance,

Saravanan.

Hall of Fame Super Blue

Re: SUP II Intervlan

psaravanan wrote:

Hi glen,

I checked the default gateway of the both PCs which is given in the vlan address of the switch.

I can ping to Switch, but one pc to another pc ping is not happen (inter vlan).

I enabled the IP routing command, but it is not shown in the running configuration.

Please the IOS version, Is it ok to configure Inter vlan or not.

Thanks in advance,

Saravanan.

Saravanan

From one of the PCs can you ping -

1) the PCs default-gateway

2) the other L3 vlan IP address on the switch

if you can do both the above then as Glen suggested it could well be firewalls on the PCs blocking the pings.

Jon

Purple

Re: SUP II Intervlan

  Sup II pluses  can all do intervlan routing .  Config looks ok .  From what  you are describing the the default gateways on the pc nic  definitions is not correct .  If FW's are turned off it should ping.  PC's on vlan1 nic settings must point to the 192.168.10.41 address , on  vlan 3 they must point to 192.168.12.1 .  .  Verify masking is also correct.   Some default commands may not show up in the config like ip routing . If you have devices hooked up and the SVI's show up/up  then if you do a "show ip route" it should show connected routes for those 2 subnets.

New Member

Re: SUP II Intervlan

Hi friends,

Please give a valuable solution for this issue.

Thanks in advance.

Regards,

Saravanan.

Hall of Fame Super Blue

Re: SUP II Intervlan

Saravanan

It would help if you read all the answers.

From one of the PCs -

1) can you ping the PC default-gateway ?

2) can you ping from the same PC the other L3 vlan IP address on the switch

Can you post -

1) "ipconfig" from both switches

2) "sh ip int brief" from the switch

3) "sh vlan brief" from the switch

4) the config for the 2 ports that the PCs connect into

Jon

New Member

Re: SUP II Intervlan

Hi Jon,

Thanks for your reply,

From one of the PCs -

1) can you ping the PC default-gateway ?

       Yes, I can to ping 192.168.12.1

2) can you ping from the same PC the other L3 vlan IP address on the switch

      Yes, I can ping to 192.168.10.41(switch IP)

Can you post -

Now I am not in the site, I have taken the backup of the tech-support information and vlan information,

Please check the below information.

Switch#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/1, Gi1/2, Gi1/3, Gi1/4
                                                Gi1/5, Gi1/6, Gi1/7, Gi1/8
                                                Gi1/9, Gi1/10, Gi1/11, Gi1/12
                                                Gi1/13, Gi1/14, Gi1/15, Gi1/16
                                                Gi1/17, Gi1/18, Gi1/19, Gi1/20
                                                Gi2/1, Gi2/2, Gi2/3, Gi2/4
                                                Gi2/5, Gi2/6, Gi2/7, Gi2/8
                                                Gi2/9, Gi2/10, Gi2/11, Gi2/12
                                                Gi2/14, Gi2/15, Gi2/16, Gi2/17
                                                Gi2/18, Gi2/19, Gi2/20, Gi2/21
                                                Gi2/22, Gi2/23, Gi2/24, Gi2/25
                                                Gi2/26, Gi2/27, Gi2/28, Gi2/29
                                                Gi2/30, Gi2/31, Gi2/32, Gi2/33
                                                Gi2/34, Gi2/35, Gi2/36, Gi2/37
                                                Gi2/38, Gi2/39, Gi2/40, Gi2/41
                                                Gi2/42, Gi2/43, Gi2/44, Gi2/45
                                                Gi2/46, Gi2/47, Gi2/48
3    test                             active    Gi2/13
1002 fddi-default                     act/unsup
1003 trcrf-default                    act/unsup
1004 fddinet-default                  act/unsup

---------------------------------------------------------------------

Switch(config)#do ping 192.168.10.9

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.9, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms

Switch(config)#do ping 192.168.10.183

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.183, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
Switch(config)#

Switch(config)#do ping 192.168.12.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Switch(config-if)#do ping 192.168.12.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms


Thanks in advance,

Regards,

Saravanan.

Silver

Re: SUP II Intervlan

Hi,

according to release notes you need at least 12.2(25)SG IOS version to support Sup-II+TS within Cat4503 chassis or 12.2(37)SG if it is Cat4503-E chassis (you are running 12.2(25)EWA7). You can try to load that (or later) version and see if there is any difference.

Best regards,

Antonin

New Member

Re: SUP II Intervlan

Hi Amikat,

SUP-II  has 32 MB flash, 12.2(37)SG require 64MB flash.

So I can't upgrade the image.

I rechecked the both pc settings, firewall is disabled in the both.

Thanks & Regards,

Saravanan

325
Views
0
Helpful
11
Replies