Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Sup720 SP Rommon looses confreg and config; nvram corrupted

I have a Sup720. At boot up it (SP) says:

System Bootstrap, Version 8.4(2) Release

Copyright (c) 1994-2005 by cisco Systems, Inc.

Testing lower main memory - data equals address

Testing lower main memory - checkerboard

Testing lower main memory - inverse checkerboard

Clearing lower memory for cache initialization

Clearing bss

Clearing autoboot state machine

Reading monitor variables from NVRAM

Warning: Rommon NVRAM area is corrupted. Initialize the area to default values

Reset reason for CPU board 0xffff , BaseBoard 0x200ffff, display 0x0

System Reset by Power On.

Enabling interrupts

Initializing TLB

Initializing cache

Initializing required TLB entries

Initializing main memory

Sizing NVRAM

Initializing PCMCIA controller

Exiting init

Cat6k-Sup720/SP processor with 524288 Kbytes of main memory

rommon 1 >

When i issue the 'confreg 0x2102' command and then the 'boot' command all goes well. The Sup720 boots up and i can configure it. Both SP and RP confreg's are now 0x2102. A reload via the 'reload' command works fine. Supervisor starts fine.

When however i switch the power supply off/on nvram is corrupted again.

First i thought about FN27595 (broken crystal) but that's only for older hardware revisions.

I even tried 'nvram_erase' but that's only for RP, not SP.

Assuming this NVRAM is really 'non volatile' (so no dead batteries), what can cause this problem?

Oh, btw, i have 4 of those, out of the box...


Community Member

Re: Sup720 SP Rommon looses confreg and config; nvram corrupted

This problem was solved, thanks to Ronan Isaac. He suggested to change the on board battery. I turned out to be exhausted. A $28,000 supervisor, a $1 battery :)

Problem solved!


CreatePlease to create content