Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SVI / VRRP Problem?

I've got a problem I can't quite pin down.

I have two 6500s running VRRP on 12.2(33)SXH3.  One particular svi on Core2, interface vlan20, is having some trouble.

Core 1:

interface Vlan20
description Server VLAN
ip address 10.100.20.2 255.255.255.0
ip flow ingress
vrrp 20 ip 10.100.20.1
vrrp 20 priority 250

!

spanning-tree vlan 20 priority 8192

Core 2

interface Vlan20
description Server VLAN
ip address 10.100.20.3 255.255.255.0
vrrp 20 ip 10.100.20.1

!

spanning-tree vlan 20 priority 16384

There's a server on this vlan with an IP of 10.100.20.86 that only Core 1 can ping.  If I ping from Core 2, it fails.  If I shutdown vlan20 on Core2, then Core2 can ping the IP just fine.

Server has the same mask as the routers and has a default gateway of the vrrp IP.

While the interface is up/up, a ping to all other IPs on that subnet (from Core2) provides 4/5 ping returns  ( .!!!! )

Any thoughts?

thanks!

5 REPLIES
Cisco Employee

Re: SVI / VRRP Problem?

How is your trunk looks like for both Core1 and Core2??

Regards,

jerry

New Member

Re: SVI / VRRP Problem?

Strange... Vlan20 isn't forwarding on Core2.  Why not?

CORE-01# show int po1 trunk

Port                Mode         Encapsulation  Status        Native vlan
Po1                 on           802.1q         trunking      1

Port                Vlans allowed on trunk
Po1                 1-4094

Port                Vlans allowed and active in management domain
Po1                 1-2,10,12,19-20,22-25,30-33,35-36,40,50-54,64,68,84,99,104,112,126,128,136,160,172,176,192,702-703,999-1000

Port                Vlans in spanning tree forwarding state and not pruned
Po1                 1-2,10,12,19-20,22-25,30-33,35-36,40,50-54,64,68,84,99,104,112,126,128,136,160,172,176,192,702-703,999-1000

CORE-02# show int po1 trunk

Port                Mode         Encapsulation  Status        Native vlan
Po1                 on           802.1q         trunking      1

Port                Vlans allowed on trunk
Po1                 1-4094

Port                Vlans allowed and active in management domain
Po1                 1-2,10,12,19-20,22-25,30-33,35-36,40,50,64,68,84,99,104,112,128,136,160,172,176,192,702-703,999-1000

Port                Vlans in spanning tree forwarding state and not pruned
Po1                 1-2,12,19,22-25,30-33,35,40,50,68,84,99,104,112,128,136,160,172,176,192,702-703,999-1000

Cisco Employee

Re: SVI / VRRP Problem?

Please post the following outputs for both switches:

show spanning-tree vlan 20

show run interface po 1

show vtp status

Regards,

jerry

New Member

Re: SVI / VRRP Problem?

CORE-01#show run int po1
Building configuration...

Current configuration : 140 bytes
!
interface Port-channel1
description EtherChannel to Core 2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
end


CORE-01#show spanning-tree vlan 20

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    4116
             Address     000d.ecea.f53c
             Cost        2
             Port        259 (TenGigabitEthernet3/3)
             Hello Time   4 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192
             Address     0014.1bf4.1c14
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 480

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te3/1               Desg FWD 2         128.257  P2p
Te3/2               Desg FWD 2         128.258  P2p
Te3/3               Root FWD 2         128.259  P2p
Te3/4               Desg FWD 2         128.260  P2p
Gi4/9               Desg FWD 4         128.393  P2p
Gi4/11              Desg FWD 4         128.395  P2p
Gi4/13              Desg FWD 4         128.397  P2p
Gi4/14              Desg FWD 4         128.398  P2p
Gi4/17              Desg FWD 4         128.401  P2p
Gi4/18              Desg FWD 4         128.402  P2p
Gi4/19              Desg FWD 4         128.403  P2p
Gi4/23              Desg FWD 4         128.407  P2p
Gi4/24              Desg FWD 4         128.408  P2p
Gi4/25              Desg FWD 4         128.409  P2p
Gi4/26              Desg FWD 4         128.410  P2p
Gi4/29              Desg FWD 4         128.413  P2p
Gi4/30              Desg FWD 4         128.414  P2p
Gi4/31              Desg FWD 4         128.415  P2p
Gi4/32              Desg FWD 4         128.416  P2p
Gi4/33              Desg FWD 4         128.417  P2p
Gi4/35              Desg FWD 4         128.419  P2p
Gi4/36              Desg FWD 4         128.420  P2p
Gi4/37              Desg FWD 4         128.421  P2p
Gi5/8               Desg FWD 4         128.520  P2p
Gi5/11              Desg FWD 4         128.523  P2p
Gi5/13              Desg FWD 4         128.525  P2p
Gi5/14              Desg FWD 4         128.526  P2p
Gi5/17              Desg FWD 4         128.529  P2p
Gi5/20              Desg FWD 4         128.532  P2p
Gi5/21              Desg FWD 4         128.533  P2p
Gi5/22              Desg FWD 4         128.534  P2p
Gi5/23              Desg FWD 4         128.535  P2p
Gi5/27              Desg FWD 4         128.539  P2p
Gi5/28              Desg FWD 4         128.540  P2p
Gi5/29              Desg FWD 4         128.541  P2p
Gi5/30              Desg FWD 4         128.542  P2p
         
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Po1                 Desg FWD 3         128.1665 P2p
Po2                 Desg FWD 3         128.1666 P2p
Po3                 Desg FWD 3         128.1667 P2p
Po5                 Desg FWD 3         128.1669 P2p


CORE-01# show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 43
VTP Operating Mode              : Transparent
VTP Domain Name                 : net
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xFB 0x40 0xC2 0x1C 0xE6 0xBC 0x6F 0xE4
Configuration last modified by 10.100.2.2 at 0-0-00 00:00:00

CORE-02#show spanning-tree vlan 20

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    4116
             Address     000d.ecea.f53c
             Cost        4
             Port        257 (TenGigabitEthernet3/1)
             Hello Time   4 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    16384
             Address     0014.1bef.2d14
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 480

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te3/1               Root FWD 2         128.257  P2p
Gi4/1               Desg FWD 4         128.385  P2p
Gi4/2               Desg FWD 4         128.386  P2p
Gi4/4               Desg FWD 4         128.388  P2p
Gi4/7               Desg FWD 4         128.391  P2p
Gi4/11              Desg FWD 4         128.395  P2p
Gi4/12              Desg FWD 4         128.396  P2p
Gi4/14              Desg FWD 4         128.398  P2p
Gi4/18              Desg FWD 4         128.402  P2p
Gi4/19              Desg FWD 4         128.403  P2p
Gi4/23              Desg FWD 4         128.407  P2p
Gi4/24              Desg FWD 4         128.408  P2p
Gi4/25              Desg FWD 4         128.409  P2p
Gi4/26              Desg FWD 4         128.410  P2p
Gi4/28              Desg FWD 4         128.412  P2p
Gi4/29              Desg FWD 4         128.413  P2p
Gi4/30              Desg FWD 4         128.414  P2p
Gi4/31              Desg FWD 4         128.415  P2p
Gi4/32              Desg FWD 4         128.416  P2p
Gi4/33              Desg FWD 4         128.417  P2p
Gi4/34              Desg FWD 4         128.418  P2p
Gi4/35              Desg FWD 4         128.419  P2p
Gi4/36              Desg FWD 4         128.420  P2p
Gi4/37              Desg FWD 4         128.421  P2p
Gi5/8               Desg FWD 4         128.520  P2p
Gi5/11              Desg FWD 4         128.523  P2p
Gi5/13              Desg FWD 4         128.525  P2p
Gi5/14              Desg FWD 4         128.526  P2p
Gi5/20              Desg FWD 4         128.532  P2p
Gi5/21              Desg FWD 4         128.533  P2p
Gi5/22              Desg FWD 4         128.534  P2p
Gi5/23              Desg FWD 4         128.535  P2p
Gi5/27              Desg FWD 4         128.539  P2p
         
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Gi5/30              Desg FWD 4         128.542  P2p
Po1                 Altn BLK 3         128.1665 P2p
Po2                 Desg FWD 3         128.1666 P2p
Po3                 Desg FWD 3         128.1667 P2p
Po5                 Desg FWD 3         128.1669 P2p

CORE-02#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 38
VTP Operating Mode              : Transparent
VTP Domain Name                 : net
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x64 0xF1 0x50 0x1A 0x62 0xD8 0x95 0x8F
Configuration last modified by 10.100.2.3 at 0-0-00 00:00:00

CORE-02#show run int po1
Building configuration...

Current configuration : 140 bytes
!
interface Port-channel1
description EtherChannel to Core 1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
end

Cisco Employee

Re: SVI / VRRP Problem?

Okay, Core2's spanning tree shows that PO1 is blocked for VL20

CORE-02#show spanning-tree vlan 20
VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    4116
             Address     000d.ecea.f53c
             Cost        4
             Port        257 (TenGigabitEthernet3/1)
             Hello Time   4 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    16384
             Address     0014.1bef.2d14
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 480
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te3/1               Root FWD 2         128.257  P2p
Gi4/1               Desg FWD 4         128.385  P2p
Gi4/2               Desg FWD 4         128.386  P2p
Gi4/4               Desg FWD 4         128.388  P2p
Gi4/7               Desg FWD 4         128.391  P2p
Gi4/11              Desg FWD 4         128.395  P2p
Gi4/12              Desg FWD 4         128.396  P2p
Gi4/14              Desg FWD 4         128.398  P2p
Gi4/18              Desg FWD 4         128.402  P2p
Gi4/19              Desg FWD 4         128.403  P2p
Gi4/23              Desg FWD 4         128.407  P2p
Gi4/24              Desg FWD 4         128.408  P2p
Gi4/25              Desg FWD 4         128.409  P2p
Gi4/26              Desg FWD 4         128.410  P2p
Gi4/28              Desg FWD 4         128.412  P2p
Gi4/29              Desg FWD 4         128.413  P2p
Gi4/30              Desg FWD 4         128.414  P2p
Gi4/31              Desg FWD 4         128.415  P2p
Gi4/32              Desg FWD 4         128.416  P2p
Gi4/33              Desg FWD 4         128.417  P2p
Gi4/34              Desg FWD 4         128.418  P2p
Gi4/35              Desg FWD 4         128.419  P2p
Gi4/36              Desg FWD 4         128.420  P2p
Gi4/37              Desg FWD 4         128.421  P2p
Gi5/8               Desg FWD 4         128.520  P2p
Gi5/11              Desg FWD 4         128.523  P2p
Gi5/13              Desg FWD 4         128.525  P2p
Gi5/14              Desg FWD 4         128.526  P2p
Gi5/20              Desg FWD 4         128.532  P2p
Gi5/21              Desg FWD 4         128.533  P2p
Gi5/22              Desg FWD 4         128.534  P2p
Gi5/23              Desg FWD 4         128.535  P2p
Gi5/27              Desg FWD 4         128.539  P2p
         
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi5/30              Desg FWD 4         128.542  P2p
Po1                 Altn BLK 3         128.1665 P2p
Po2                 Desg FWD 3         128.1666 P2p
Po3                 Desg FWD 3         128.1667 P2p
Po5                 Desg FWD 3         128.1669 P2p

What switch is this 0014.1bef.2d14 root bridge? You need to trace the spanning tree to look for inconsistance toward the root.

Regards,

jerry

999
Views
0
Helpful
5
Replies