Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

%SW_MATM-4-MACFLAP_NOTIF

I have read other discussions in the forum regarding this error but I was unable to relate my particular problem to the solutions posted in the other discussions to this syslog error, so I have started a new disucssion hoping to find the cause and a solution.

This error is quite segreated from most of my network.  It only exists on 3 Vlans that only exist on 2 Cisco 3560s that are each connected to a 6509 VSS pair via a PAgP port-channel, there is a firewall services module in the 6509 that does sit in between the vlans as well.

Jun 12 22:01:55.163 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 0050.5687.38f8 in vlan 70 is flapping between port Gi0/21 and port Po1

Jun 12 22:01:55.482 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 0050.5687.38fa in vlan 70 is flapping between port Gi0/20 and port Po1

Jun 12 22:08:42.895 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 0050.5687.38f2 in vlan 1070 is flapping between port Gi0/26 and port Po1

Jun 12 22:08:51.736 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 0050.569e.09c8 in vlan 2564 is flapping between port Gi0/25 and port Po1

There are 9 servers that each have a connection to both 3560s.  All hosts on the servers are ESXi if that helps.  On each of the 3560s there are about 30 of these messages

This is the uplink from each 3560 to the VSS pair

interface Port-channel1

description Uplink to VSS

switchport trunk encapsulation dot1q

switchport trunk native vlan 666

switchport trunk allowed vlan 3,70,71,210,666,1070,2225,2564

switchport mode trunk switchport nonegotiate

interface GigabitEthernet0/51

description Core A

switchport trunk encapsulation dot1q

switchport trunk native vlan 666

switchport trunk allowed vlan 3,70,71,210,666,1070,2225,2564

switchport mode trunk

switchport nonegotiate

udld port

channel-protocol pagp

channel-group 1 mode desirable

end

interface GigabitEthernet0/52

description Core B

switchport trunk encapsulation dot1q

switchport trunk native vlan 666

switchport trunk allowed vlan 3,70,71,210,666,1070,2225,2564

switchport mode trunk

switchport nonegotiate

udld port

channel-protocol pagp

channel-group 1 mode desirable

The other 3560 config to the VSS pair is identical to that.  Any guidance you can provide is greatly appreciated

Thanks Matt

Everyone's tags (3)
2 REPLIES
Hall of Fame Super Bronze

%SW_MATM-4-MACFLAP_NOTIF

You need to disable NIC teaming on the servers. It seems they are broadcasting the same MAC address via each physical switch.

If you want to keep NIC teaming on the servers, connect them to the VSS pair or get some 3750 stackable switches at the edge.

%SW_MATM-4-MACFLAP_NOTIF

The MAC address looks to be one of those in the range that VMware ESXi allocates to the virtual machines (VM) that are running on the ESXi host.

If that's the case then the ESXi server is alternating which physical NIC is being used to carry the traffic for a particular VM.

Do you know which load balancing algorithm is configured on the ESXi hosts? I've seen this before when the ESXi hosts were setup for Route based on IP hash (VMware terminology for Link Aggregation), but we hadn't set the network switches and ports to the server for Link Aggregation.

Regards

446
Views
0
Helpful
2
Replies
CreatePlease login to create content