Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

switch 2960 issue

hi,

i have one WAN router (i.e. juniper router). on internal port i have configured two public ip( 56.10.45.225/27 & 56.10.246.97/28)

i have connect this router to my switch 2960-s by  fiber uplink and created SVI on switch VLAN 1.all ports of switch belog to vlan 1 only.

and i have connected the servers to same switch.

Now the problem is i can reach to gateway i.e. 45.255 & 246.97 from the servers and not able to reach from the switch.i am not able to ping the gateway address from the switch.

I configured default gateway as primary IP of router i.e. 45.225.

What can be an issue, how do i troubleshoot.

Regards,

Wajid

1 REPLY

Re: switch 2960 issue

Hi Wajid,

when the server can reach the the gateways and you're using VLAN 1 only, we can assume that Layer-2 works.

1) Check the IP configuration of the SVI:

show ip interface vlan1

Vlan1 is up, line protocol is up
  Internet address is 192.168.1.4/24

  (...)

2) Check that the default-gateway is within the same subnet as VLAN 1

show run | i default-gateway
ip default-gateway 192.168.1.1

3) Check ARP resolution for the default-gateway:

show ip arp 192.168.1.1

Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.1.1         55   0000.0c08.bc01  ARPA   Vlan1

4) Check CAM table entry for the MAC-address:

show mac address-table address 0000.0c08.bc01

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

   1    0000.0c08.bc01    DYNAMIC     Gi0/1

HTH

Rolf

103
Views
0
Helpful
1
Replies