cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
862
Views
0
Helpful
6
Replies

Switch 3560G configuration help require

pannu3679
Level 1
Level 1

Hi All,

I'm configuring this switch for AVAYA PABX. At moment, I have configured 2 VLANs. VLAN1 is my voice VLAN and VLAN2 is my DATA VLAN. I have also configured IP routing for inter vlan communication. I am not sure how do I configure DHCP so that when my PC connect with AVAYA phone then it should get different IP address and AVAYA phone is going to directly connect with the switch and it should get different IP address.

Please find following switch config which I have done it so far....

=======================================

INDOFFICESWI01#sh running-config

Building configuration...

Current configuration : 2654 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname INDOFFICESWI01

!

enable secret xxx

!

no aaa new-model

ip subnet-zero

ip routing

!

!

!

!

dot1x system-auth-control

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/1

switchport access vlan 2

switchport mode access

switchport voice vlan 1

mls qos trust dscp

!

interface GigabitEthernet0/2

switchport access vlan 2

switchport mode access

switchport voice vlan 1

mls qos trust dscp

!

interface GigabitEthernet0/3

switchport access vlan 2

switchport mode access

switchport voice vlan 1

mls qos trust dscp

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

!

interface GigabitEthernet0/28

!

interface GigabitEthernet0/29

!

interface GigabitEthernet0/30

!

interface GigabitEthernet0/31

!

interface GigabitEthernet0/32

!

interface GigabitEthernet0/33

!

interface GigabitEthernet0/34

!

interface GigabitEthernet0/35

!

interface GigabitEthernet0/36

!

interface GigabitEthernet0/37

!

interface GigabitEthernet0/38

!

interface GigabitEthernet0/39

!

interface GigabitEthernet0/40

!

interface GigabitEthernet0/41

!

interface GigabitEthernet0/42

!

interface GigabitEthernet0/43

!

interface GigabitEthernet0/44

!

interface GigabitEthernet0/45

!

interface GigabitEthernet0/46

!

interface GigabitEthernet0/47

!

interface GigabitEthernet0/48

!

interface GigabitEthernet0/49

!

interface GigabitEthernet0/50

!

interface GigabitEthernet0/51

!

interface GigabitEthernet0/52

!

interface Vlan1

description Voice VLAN

ip address 192.168.254.100 255.255.255.0

!

interface Vlan2

description Data VLAN

ip address 192.168.252.100 255.255.255.0

!

ip classless

ip http server

=======================================

I've configured first 3 ports for testing purpose... You quick help will be much more appreciated...

Also, want to inform you that at present my PABX ip is in the range of 192.168.254.x. and that is the reason I have keep VLAN1 IP in this range.

Thanks,

Pans

6 Replies 6

chriswill
Level 1
Level 1

Try this config below

!Fisrt define a Dhcp pool

!

ip dhcp pool Data

network 192.168.252.0 255.255.255.0

default-router 192.168.252.100

!

!

ip dhcp pool Voice

network 192.168.254.0 255.255.255.0

default-router 192.168.254.100

!

!

! This makes sure that dhcp doesn't give the vlan address out to a host

ip dhcp excluded-address 192.168.254.100

ip dhcp excluded-address 192.168.252.100

You may want to change your trust on the ports to only trust the ip phone rather than any dscp value coming in from either phone or pc. Some applications are capable of putting in there own dscp values which may not be what you want.

Hope this helps

Chris

Hi Chris,

Thanks very much for your quick response.. I am going to connect my AVAYA phone to CISCO switch and PCs are going to connect with AVAYA phone..

I am planning write following command instead of mls qos trust dscp.

mls qos trust cos

Do I also need to write auto qos voip trust command ?

Your help will be much more appreciated...

THanks,

Hello,

I am going to connect my AVAYA phone to CISCO switch and PCs are going to connect with AVAYA phone..

I am planning write following command instead of mls qos trust dscp.

mls qos trust cos

Do I also need to write auto qos voip trust command ?

Your help will be much more appreciated...

THanks,

Hi,

You will not need any mls commands on the interface.I would probably set up a class-map to match the voice traffic and then a policy-map to set the cos rating, then apply it to the vlan interface on the incoming side.

Example:

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos

access-list 1 permit 192.168.254.0 0.0.0.255

access-list 2 permit 192.168.252.0 0.0.0.255

class-map match-all Voice

match access-group 1

class-map match-all Data

match access-group 2

policy-map Phone_Data

class Voice

set ip dscp ef

class Data

set ip dscp af23

! On the interface that is the trunk port apply these commands

service-policy input Phone_Data

mls qos trust cos

Try that I think it should be ok

Chris

cjinfantino
Level 1
Level 1

Hey,

If I understand your question correctly you want to plug your phone into one of the switchports and have that get it's own IP address from vlan1 that you have setup, if that is the case you need to set up a new DHCP scope with the correct range of address that it should give out. Also one of the scope options needs to be the ip address of your vlan1 interface.

In addition, if your DHCP server is separated from this switch by a router or multi-layer switch you need to define the DHCP server's address as a helper address on that router or multi-layer switch. This will allow the phones DHCP request packet to be forwarded on to the DHCP server.

Lastly, it is 'best practice' to not use int vlan1 because the switches use that vlan to communicate cdp, stp, etc.

I hope this helps, if I have misunderstand your question I apologize.

hi,

No, you understood it perfectly. I have some requirement that is the reason I have used vlan1 for voice traffic.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: