Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Switch Configuration - Pls help

Hi,

I am new to do practical implemention of data networking so have few small small questions, hope someone will help me.

I have two racks in which i have servers, Rack 1 is active and rack 2 is secondary.

on rack 1 i have one L3 switch and same as in rack 2

Customer network has Layer 2 architecture, my two switches will go to core switches for the access to AD/firewall/ and other applications

now i have created 2 vlans on both switches, nic 1 from one server in rack 1 is going to Vlan 1 of switch 1 and nic 2 is going to Vlan 2 of switch 2 of rack 2. and same for rack 2 components...

First question..is this design good?

2) how to do communication b/w two switches? is it via cross cable ? or should i use gig ports?

3) if cross cable than i have to make that port on both switches as trunk.?

currently all the ports are access.

4) which port/link will goto core switch? will this port be trunk as well?

as of now i have these questions, please help..

Thanks,

-Daljeet

6 REPLIES

Re: Switch Configuration - Pls help

Hi

U can team the servers nic's and connect them to two switches.they should be in same vlan.

U need to configure a trunk link between u r switches.

U r core switches will be doing the routing.

U need to have a trunk link between u r access or dist or core switches.

Thanks

Mahmood

New Member

Re: Switch Configuration - Pls help

Just to add to Mahmood's notes. If you are using windows OS, then then you would use the term teaming for the NICS. If you are using LINUX then you would bond the interfaces.

If the reason for having VLAN 1 and VLAN 2 is to have diffierent IP sunbets assigned to each NIC then you do not want to TEAM or BOND the interfaces and having two VLANS is correct. If they are going to be on the same IP subnet then you only need the single VLAN.

I would leave VLAN 1 as native and use VLAN 2 for your active traffic.

You definately want to set a trunk between the switches so the VLAN tag will be added to the Frames/Packets going between the switches.

Frank

New Member

Re: Switch Configuration - Pls help

Thanks Frank and Mahmood,

You got it correctly, we cant use NIC teaming for the servers as the deployment is for Cisco IPCC and ICM and CVP doesnt support nic teaming.

That the reason we are using more than one VLAN's..

I am not running any voice on the switches so why do we require trunking to connect access switch to core? as yesterday i pull one cross over cable from core switch and terminated to my access switch and after doing the basic connectivity i was able to reach internet(Please note the ports on both the access and core switches were access not trunk)

And right now i have only one switch configured where i have two vlans to segregate two nic traffic..but now i want to configure another switch in rack two. So want to verify how to make these switches communicate,

As far as my understanding goes, i just have to extend my VLAN's to new switch and all will work fine. What say?

Any comment will be appreciated

New Member

Re: Switch Configuration - Pls help

Dear Daljeet,

Find the attached network diagram.

try following things:

1. configure HSRP between layer 3 switch 1 and 2.

2. configure all the ports ( connected from one switch to other as trunk ports)

3.configure all the other ports as access ports.

4. connect 1 connection from the server to layer 2 switch 1 and other to layer 2 switch 2.

5.configure teaming between those 2 server ports.

Regards

Raj

New Member

Re: Switch Configuration - Pls help

Hey Raj,

Thanks for your reply, points 1-3 looks relavent to me, for pt 5, we cant use nic teaming as the software we are using on servers doesnt supports nic teaming.

rest all the steps looks very ok to me..i will give them try today or tomorrow first half.

thanks mate..

Silver

Re: Switch Configuration - Pls help

Couple of best practices.

1. Keep VLAN 1 for management

2. Build VLAN VTP Domain so all switches can communicate between each other and have one location for building VLAN's. Since they are L3 switches choose the VTP Server to do all the intervlan routing.

For example:

SW1

conf t

!

int vlan 1

description Management VLAN

ip address 10.1.1.1 255.255.255.0

no shut

!

int vlan 2

description Server Nic1

ip address 10.1.2.1 255.255.255.0

no shut

!

int vlan 3

description Server Nic2

ip address 10.1.3.1 255.255.255.0

no shut

!

int vlan 4

description Server Managment Port

ip address 10.1.4.1 255.255.255.0

no shut

!

vtp domain

vtp mode server

!

interface G0/1

description Trunk Port to Switch 2

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan all

no shut

!

interface G0/2

description Server A Nic1

switchport access vlan 2

spanning-tree portfast

no shut

!

interface G0/3

description Server A Nic2

switchport access vlan 3

spanning-tree portfast

no shut

!

and it goes on and on from there.

Connection between 2 swiches is via cross over cable from interface to interface.

From the main switch or from both switches youwould build the same type of trunk port from an interface to the core. My suggestion would be to dual link the switches.

Link them together via trunk, and link each switch seperately to the core, that way no matter what they have access to the core, unless the core goes down.

Please rate if this helps

-Rick

136
Views
0
Helpful
6
Replies
CreatePlease login to create content