Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Switch connectivity issue

This is probably a simple one, but driving me crazy nonetheles

s...

I have a small lab setup, router, switch, PC.  I am setting up a small VoIP lab and configuring the VLANs and trunking for VoIP to function, but have run into something that I'm not sure is "normal" or not.  Router and PC are both directly connected to the switch.  I have the router ethernet int configured with two subinterfaces, one for data, and one for Voice.  The connection between the router and switch is setup with a dot1q trunk.  The PC is in the Data VLAN which matches the "Data" subinterface on the router.  I can ping both the router and switch from the PC.  I cannot ping the PC from the router, not can I ping the PC from the switch.

Router interface:

interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
description Router Voice Vlan Interface
encapsulation dot1Q 10
ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0.50
description Router Data Vlan Interface
encapsulation dot1Q 50
ip address 192.168.2.3 255.255.255.0

Switch:
interface FastEthernet0/21
description Router Interface Trunk
switchport mode trunk
!
interface FastEthernet0/22
!
interface FastEthernet0/23
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan50
ip address 192.168.2.2 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.2.3

Can someone shed some light on this one?

Thanks

Dan

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Switch connectivity issue

daniel.vaughn wrote:

I have the f/w turned off, and can ping the router from the PC.

There doesn't look to be anything wrong with your config. If you can ping the router from the PC and the swith as well but not the other way round then something on the PC is blocking incoming ICMP echo requests.

Jon

4 REPLIES
Hall of Fame Super Blue

Re: Switch connectivity issue

Dan

If you can ping from the PC but not to the PC sounds like you might have a firewall running on your PC.

Jon

New Member

Re: Switch connectivity issue

I have the f/w turned off, and can ping the router from the PC.

Hall of Fame Super Blue

Re: Switch connectivity issue

daniel.vaughn wrote:

I have the f/w turned off, and can ping the router from the PC.

There doesn't look to be anything wrong with your config. If you can ping the router from the PC and the swith as well but not the other way round then something on the PC is blocking incoming ICMP echo requests.

Jon

New Member

Re: Switch connectivity issue

I checked my f/w again, and you were exactly right...hate that when that happens....sheesh!

Thanks Jon!

245
Views
0
Helpful
4
Replies