Cisco Support Community
Community Member

Switch Modules

My network generally runs older routers (2600 series) with 16 port switch modules (NM-ESW-16).   This has always worked great since I can configure the router and the switch ports on the fly, making changes to either as necessary. 

   Well I am upgrading to 2811 routers, and we wanted to get gigabitethernet ports on our switch modules.  I think I made an error when I purchased a few of these switch modules:  NME-16ES-1G.   

The first problem, is that the switch ports don't even show up on the router config, I have to establish a session into the switch, (And I can't seem to get back to the router unless I manually switch off power and restart).  I don't like this type of switch module, it's like I'm running a completely separate device, and while having a layer 3 switch is cool, It doesn't let me setup routing protocols so I don't like doing it this way.  I want to go back to using a switch module that simply adds a ton of ports to my router like the NM-ESW-16.  (Note:  The NM-ESW-16 does actually work in the 2811 and would be perfect if it were Gigabit speed.)

  The seconds problem is that the NME-16ES-1G isn't actually a Gigabit switch.  It has a single gigabit port, but the 16 ports are all Fastethernet, and not gigabitethernet. 

  So ideally, I am looking for a switch module that I can fully configure from the router interface that has 16 gigabitethernet ports, and works with a 2811.   Is tehre such a thing?

  IE I want to do this... (Sample config I just made up on the fly illustrating what I'm looking for)

#Router  sho run


Interface GigabitEtherenet 0/0


Interface Gigabit Etherenet 0/1


Interface Gigabitetherenet 0/1

switchport access vlan 5

Interface GigabitEthernet 0/2

switchport access vlan 5

Interface Gigabitetherenet 0/3

switchport access vlan 10

Interface GigabitEthernet 0/4

switchport access vlan 11


Interface GigabitEthernet 0/15

switchport mode trunk

router ospf 10

network 100.100.100 0 area 1

network area 0

interface vlan 5

description Company Vlan

ip address

interface vlan 10

description guest vlan

ip address

VIP Super Bronze

Re: Switch Modules

You shouldn't need to turn off the router.  After you login to the switch, to suspend a Telnet session, enter the escape sequence Ctrl-Shift-6 x(press Control-Shift-6 , let go, then press x.

These switches are all 3560 switch modules that are sitting inside the router. There isn't a way to configure these switches from the router.


Community Member

Switch Modules

Thanks, that did help me get out of the switch module session and back to the router. 

I've been browsing several hardware sites and can't seem to find anything more advanced than the NM-ESW-16 module that would suit my ideal purpose.   I know they are old, but do you think they might be the best option for 2811's? 

  @Edwin - That is wild that 2811 is now EOL.  I just bought several of them and am unlikely to upgrade to 2900 series any time soon, but thank you for the suggestion.

Switch Modules

No problem.  They're end of sale, but you can still get support through late 2016.

Good luck! -Ed

Switch Modules

Yes, you are in fact establishing a session to a separate device running it's own IOS (they are actually 3750 in network module format).  I believe you can get upgraded IOS above the standard IP BASE image for them.  Reza already gave you the command sequence to switch between sessions.  You can also set up vty sessions if you like - once configured.

Just wanted to be sure you were aware the 2811 has received it's EOS / EOL notice:

I haven't checked - but the 2900 series may have a module with the capability you're looking for.

CreatePlease to create content