Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Switch not detecting connection

Hey everyone,

I feel like I'm missing something really simple here... I'm trying to connect an interface on a module plugged into my 4900M switch. I have the interface activated, but there is no connection, no link lights, no activity whatsoever. It appears that all interfaces on this module are not functioning (the status light is on and green and the switch seems to recognize everything).

The switch is a Cisco Catalyst 4900M

The expansion module is model WS-X4908-10G-RJ45

Current configuration : 3056 bytes

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service compress-config

!

hostname labswitch

!

boot-start-marker

boot system bootflash:cat4500e-entservicesk9-mz.151-1.SG2.bin

boot-end-marker

!

!

enable secret 5 $1$Kc9I$61LiJVJa3q8vjXtFHJ/zT1

enable password hackme4fun!

!

username test privilege 15 password 0 test

username roman password 0 hackme4fun privilege 15

username view

no aaa new-model

!

ip vrf mgmtVrf

!

ip domain-name cyber

!

!

vtp mode transparent

!

!

!

power redundancy-mode redundant

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 2

!        

vlan 10

name AARC1

!

vlan 11

name AARC2

!

vlan 12

name AARC3

!

ip tftp source-interface FastEthernet1

!

!

interface FastEthernet1

ip vrf forwarding mgmtVrf

ip address 192.168.1.29 255.255.255.0

speed auto

duplex auto

!

interface TenGigabitEthernet1/1

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface TenGigabitEthernet1/2

switchport access vlan 11

switchport mode access

spanning-tree portfast

!

interface TenGigabitEthernet1/3

switchport access vlan 12

switchport mode access

spanning-tree portfast

!

interface TenGigabitEthernet1/4

switchport mode access

authentication port-control auto

spanning-tree portfast

!

interface TenGigabitEthernet1/5

switchport mode access

spanning-tree portfast

!

interface TenGigabitEthernet1/6

switchport mode access

spanning-tree portfast

!

interface TenGigabitEthernet1/7

switchport mode access

spanning-tree portfast

!

interface TenGigabitEthernet1/8

switchport mode access

spanning-tree portfast

!

interface TenGigabitEthernet2/1

switchport access vlan 12

switchport mode access

spanning-tree portfast

!

interface TenGigabitEthernet2/2

!

interface TenGigabitEthernet2/3

!

interface TenGigabitEthernet2/4

!

interface TenGigabitEthernet2/5

!

interface TenGigabitEthernet2/6

!

interface TenGigabitEthernet2/7

!

interface TenGigabitEthernet2/8

!

interface GigabitEthernet2/9

switchport access vlan 12

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet2/10

!        

interface GigabitEthernet2/11

!

interface GigabitEthernet2/12

!

interface GigabitEthernet2/13

!

interface GigabitEthernet2/14

!

interface GigabitEthernet2/15

!

interface GigabitEthernet2/16

!

interface Vlan1

ip address 192.168.1.30 255.255.255.0

!

interface Vlan10

ip address 10.1.0.1 255.255.0.0

!

interface Vlan11

ip address 10.2.0.1 255.255.0.0

!

interface Vlan12

ip address 10.3.0.1 255.255.0.0

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 180 life 360 requests 25

!

!

!

!

!

banner motd ^Comans Cyber Lab

Cyber Lab^C

!

line con 0

stopbits 1

line vty 0 4

password terminal-password

login

line vty 5 15

password terminal-password

login

!

!        

monitor session 1 source interface Te1/3

monitor session 1 destination interface Te1/4

monitor session 1 filter packet-type good rx

end

TenGig1/1-8 are fiber modules plugged into the switch, and are functioning normally.

TenGig2/1-8 refer to physical 10G ethernet ports. Included in this is GI2/9-16. I'm not sure what those are referring to, as the module only has 8 ports and there are no other modules installed... When we remove the module, however, the GI ports dissapear along with TenGig2/1-8

TROUBLESHOOTING STEPS COMPLETED:

Restarted the device

Removed the module/Reinsterted

Changed cable with known functioning CAT6 cable

Attached interface to known functioning network

Assigned interface to VLANS 1 and 12

Attempted to configure GI2/9 with the same configuration of TenGig2/1

Any ideas? Thanks for all of your help in advance!

3 REPLIES
Hall of Fame Super Gold

Switch not detecting connection

Changed cable with known functioning CAT6 cable

The link is a copper link?  Have you done a TDR?

I am not sure if the 4900M supports TDR

New Member

Re: Switch not detecting connection

I don't believe the 4900M supports TDR..

I did actually discover what the issue was via this thread: https://supportforums.cisco.com/thread/2177060

Ivan Shirshin

The ports cannot auto negotiate to Gigabit speeds, that is why it shows TenGigabit ports or Gigabit ports.

You can check the current settting for each port group below:

Switch#sho hw-module module 3 port-group

Module Port-group Active                         Inactive

-------------------------------------------------------------

   2        1     Te2/1-2                        Gi2/9-10

   2        2     Te2/3-4                        Gi2/11-12

   2        3     Te2/5-6                        Gi2/13-14

   2        4     Te2/7-8                        Gi2/15-16

The command to change between TenG and Gb modes is "hw-module module 2 port-group 1 select gigabitethernet"

Purple

Switch not detecting connection

  These switches have dual speed ports and you have to select what you want use , whether 10 gig or 1 gig . Might be something like that , check out interface config. 

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst4500/12.2/31sga/configuration/guide/sw_int.html#wp1066964

245
Views
0
Helpful
3
Replies
CreatePlease login to create content