Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

switch port is up, but VLAN interface is down

Hello Please help me

Scenario: I got a new Cisco 4510, setup vlans and vlan interfaces, all un-shuted, and connected few things, the problem is on, say port A, connecting on a carrier device.

Problem: no matter which vlans I setup on the switch port A, only port A in that vlan, switch port A is up, but vlan interface is down.  setup vlans on other connected ports, only one port in that vlan, vlan interfaces came up straight away.

Things I have tried but cannot fix the issue:

1, changed the cable connecting to that carrier device.

2, moved the cable to another switch port.

3, tried different vlans and vlan interface, created new, but they all didn't work on whatever the port connecting to the carrier, and they all worked on other ports.

My question, in what situation can a switch port is up connected, but the binded vlan interface is still down?

what can I do now?

 

thanks a lot.

 

3 REPLIES
Community Member

Also, I've reload the 4510,

Also, I've reload the 4510, but could not fix the issue still.

Hi,that sounds odd.With STP

Hi,

that sounds odd.

With STP enabled, the SVI should come up as soon as the first physical port in that VLAN (access or trunk) moves into the forwarding state. With STP disabled, at least one port in that VLAN just has to be up/up.

You could exclude certain ports from beeing checked with the "switchport autostate exclude" command but I don't think you did something like that.

Have you already checked the STP state of "port A"?

Could you perhaps share the output of

- show interface <port-A> status

- show interface <port-A> switchport

- show vlan id <vlan-id-of-port-A>

- show spanning-tree vlan <vlan-id-of-port-A>

- show ip int brief vlan <vlan-id-of-port-A> (you can remove the IP if it's public)

 

Best regards

Rolf

Hall of Fame Super Gold

I agree that the requested

I agree that the requested output will be very helpful. I am wondering if it is possible that the layer 2 vlan was not correctly configured. The requested outputs should make that issue clear.

 

HTH

 

Rick

852
Views
0
Helpful
3
Replies
CreatePlease to create content