cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
526
Views
0
Helpful
2
Replies

SWITCH Port w/ Two VLANs?

Hello,

I need to setup Voice and Data VLAN. (Setup - PoE phone connects to the switch, PC connects to the phone)

Say like, I'm connecting the phone to Fa0/1, and I need the phone and the PC to be on a different VLAN using the same switch port Fa0/1. Is it possible? Is there a sub-interface on switches?

My old setup was that all ODD ports where on VLAN 10 for DATA and EVEN ports on VLAN 150 for VOICE.

What is your current setup?

Please feel free to toss in some recommendation. Thanks in advance.

1 Accepted Solution

Accepted Solutions

John Blakley
VIP Alumni
VIP Alumni

Generally, you'd configure your switchport like:

int fa0/1

switchport mode access

switchport access vlan 10

switchport voice vlan 150

Some implementations, like mine for instance, use trunk ports because I don't have Cisco switches everywhere:

int fa0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchpor trunk native vlan 10

switchport trunk allowed vlan 10,150

Then your phone would be responsible for tagging the 150 vlan. The most preferred is the first one.

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

2 Replies 2

John Blakley
VIP Alumni
VIP Alumni

Generally, you'd configure your switchport like:

int fa0/1

switchport mode access

switchport access vlan 10

switchport voice vlan 150

Some implementations, like mine for instance, use trunk ports because I don't have Cisco switches everywhere:

int fa0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchpor trunk native vlan 10

switchport trunk allowed vlan 10,150

Then your phone would be responsible for tagging the 150 vlan. The most preferred is the first one.

HTH,

John

HTH, John *** Please rate all useful posts ***

Ganesh Hariharan
VIP Alumni
VIP Alumni

lumuluhang_payaso wrote:

Hello,

I need to setup Voice and Data VLAN. (Setup - PoE phone connects to the switch, PC connects to the phone)

Say like, I'm connecting the phone to Fa0/1, and I need the phone and the PC to be on a different VLAN using the same switch port Fa0/1. Is it possible? Is there a sub-interface on switches?

My old setup was that all ODD ports where on VLAN 10 for DATA and EVEN ports on VLAN 150 for VOICE.

What is your current setup?

Please feel free to toss in some recommendation. Thanks in advance.

Hello ,

As stated in above post you can try the below configuration template

config t

interface FastEthernet 2/3

switchport mode access

switchport access vlan 15

switchport voice vlan 16

OR

config t

interface FastEthernet 2/3

switchport mode access

switchport access vlan 16

switchport voice vlan dot1p

Hope to Help !!

Ganesh

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card