Cisco Support Community
Community Member

Switch Ports Disabled

Some numbers of Cisco 2950 Catalyst Switch ports have gone disabled. Whenever a "no shutdown" command is issued, it says the port cant be brought up because it has been disabled.

I've tried to use Spanning-tree to detect if there are blocked ports or inconsistent ports, i did not find any.

Kindly provide me with any solution that that can be used to bring up the interfaces/ports.

Thank you.


Re: Switch Ports Disabled

To bring them back up, you need to shut them first.


no shutdown

Hope that helps.

Cisco Employee

Re: Switch Ports Disabled


You can follow Collin's advice to do a "shutdown" "no shutdown" to get the port back online. But you should also try to find out why these port goes into the disabled state

show interface fx/x



Community Member

Re: Switch Ports Disabled

Thank you for your response.

I have done issued that command several times.

At bootup, it shows error messages like : -

int fa0/17 FAILED front-end loopback test.

Then when I issue shutdown/no shutdown command, it gives this error message, stating:

interface fa0/17 can't be brought up because it failed POST in loopback test.

I have also use the err-disable command, but nothing worked.

Does this mean the ports are permanently damaged?

Kindly help. Thanks.

Re: Switch Ports Disabled

Nonfatal-Port loopback test.

If this test failed, it means some port functionality to one or more ports is lost. The switch disables any port(s) that failed this test, and the POST failure message on the indicates which port(s) did not pass this test. You should connect only to ports that have passed this test.

RMA the switch as quickly as you can.

Cisco Employee

Re: Switch Ports Disabled

Agree with Collin.




Re: Switch Ports Disabled

Do a show interface status and see if the ports say err-disabled , if so then just "shut, then no shut as previously indicated. It should tell you in the logs why the switch put them into the err-disabled . It can be configured to automatically try to bring the ports back up after a period of time.

CreatePlease to create content