Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Switch Trucking with multiple connections

I am a fairly basic configs that I just can’t figure out what I am doing wrong.  I have what I would consider a fairly basic config that I just can’t seem to get to work and I am sure it is something I am just not doing or grasping.   Basically I have two 3560 switches that I would like to connect together with four 1Gb ports and trunk four vlans across said port-channel, I created the port-channel and set it to switchport trunk encapsulation dot1q I then set all four ports to channel-group # mode on.  With that setup I can’t ping from switch to switch on the nonnative vlan.   

Any help would be appreciated

Thanks

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Switch Trucking with multiple connections

interface Port-channel1

switchport trunk encapsulation dot1q

Something is missing in this line interface.  Can you please add "switchport mode trunk"?

6 REPLIES

Switch Trucking with multiple connections

The first thing I would do is reload the switches, no kidding. I've configured etherchannel before and just couldn't get it working and then I reloaded the switches and everything is workring fine.

If it doesn't work, post your configs.

Hall of Fame Super Gold

Switch Trucking with multiple connections

Please post the config.

New Member

Switch Trucking with multiple connections

dc01-sw02#show run

Building configuration...

Current configuration : 2383 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log datetime

service password-encryption

service sequence-numbers

!

hostname dc01-sw02

!

no aaa new-model

ip subnet-zero

!

!

!

!

port-channel load-balance src-dst-ip

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface Port-channel1

switchport trunk encapsulation dot1q

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

switchport access vlan 128

!

interface GigabitEthernet0/7

switchport access vlan 128

!

interface GigabitEthernet0/8

switchport access vlan 128

!

interface GigabitEthernet0/9

switchport access vlan 128

!

interface GigabitEthernet0/10

switchport access vlan 128

!

interface GigabitEthernet0/11

switchport access vlan 128

!

interface GigabitEthernet0/12

switchport access vlan 128

!

interface GigabitEthernet0/13

switchport access vlan 128

!

interface GigabitEthernet0/14

switchport access vlan 240

!

interface GigabitEthernet0/15

switchport access vlan 240

!

interface GigabitEthernet0/16

switchport access vlan 240

!

interface GigabitEthernet0/17

switchport access vlan 240

!

interface GigabitEthernet0/18

switchport access vlan 240

!

interface GigabitEthernet0/19

switchport access vlan 240

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

switchport access vlan 128

!

interface GigabitEthernet0/23

switchport trunk encapsulation dot1q

channel-group 1 mode on

!

interface GigabitEthernet0/24

switchport trunk encapsulation dot1q

channel-group 1 mode on

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

no ip address

!

interface Vlan128

ip address ###.#.#.### 255.255.255.0

!

ip default-gateway ###.#.#.###

ip classless

ip http server

!

end

dc01-sw02#

Hall of Fame Super Gold

Switch Trucking with multiple connections

interface Port-channel1

switchport trunk encapsulation dot1q

Something is missing in this line interface.  Can you please add "switchport mode trunk"?

New Member

Switch Trucking with multiple connections

That worked, it is always seems to be and issue with just one line.

Thanks

Hall of Fame Super Gold

Switch Trucking with multiple connections

Glad to be of some assistance.

787
Views
0
Helpful
6
Replies
CreatePlease to create content