Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Switch Trunking PRoblem - Desirable mode

Hi Experts,

I have one switch, fa0/0 connected to Router which has dot1q at g0/1.2

But I am puzzling why the switch access mode desirable is not able to bring the vlan across to the router. As What i thought is desirable is an auto setting that will tag the router's dot1q.

COnfig as below:

Switch End

-----------

Interface FastEthernet0/0

switchport mode dynamic desirable

Router End

------------

interface GigabitEthernet0/1

ip address 16.11.22.254 255.255.255.0

ip helper-address 16.11.2.23

ip helper-address 16.11.1.23

no ip redirects

no ip proxy-arp

duplex full

speed 100

!

interface GigabitEthernet0/1.2

encapsulation dot1Q 2

ip address 16.11.20.254 255.255.255.0

ip helper-address 16.11.2.23

ip helper-address 16.11.1.23

no ip redirects

no ip proxy-arp

ntp disable

bridge-group 1

bridge-group 1 input-lsap-list 101

bridge-group 1 input-type-list 100

bridge-group 1 output-lsap-list 101

bridge-group 1 output-type-list 100

bridge-group 1 input-pattern-list 1200

Thanks in advanced..

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Switch Trunking PRoblem - Desirable mode

Hi Cindy,

The command "switchport mode dynamic desirable" negotiates if the port should be access or trunk, and has nothing to do with which vlan the access port should be a member of.

Moreover, routers doesn't support DTP, and thus if your wish is to have the port as trunk you'll need to configure it with "switchport mode trunk" on the switch side.

HTH,

Mohammed Mahmoud.

5 REPLIES

Re: Switch Trunking PRoblem - Desirable mode

Hi Cindy,

The command "switchport mode dynamic desirable" negotiates if the port should be access or trunk, and has nothing to do with which vlan the access port should be a member of.

Moreover, routers doesn't support DTP, and thus if your wish is to have the port as trunk you'll need to configure it with "switchport mode trunk" on the switch side.

HTH,

Mohammed Mahmoud.

New Member

Re: Switch Trunking PRoblem - Desirable mode

Hi Mahmoud,

Great answer ya..:)

Understood.

Thanks!

Re: Switch Trunking PRoblem - Desirable mode

Hi Cindy,

You are very welcomed :), i am glade that i've been informative, and thank you for using the rating system.

BR,

Mohammed Mahmoud.

Purple

Re: Switch Trunking PRoblem - Desirable mode

A router cannot negotiate a trunk with desirable mode , thus all trunks from switches to routers must be forced on , "switchport mode trunk" . Desirable will work between switches or l2/l3 switches , options for each end would be desirable/desirable or desirable/auto on each end.

New Member

Re: Switch Trunking PRoblem - Desirable mode

Thanks Glen.Make my understanding on this trunking related even better..:) appreciate that.

248
Views
9
Helpful
5
Replies
CreatePlease to create content