Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Switch WS-C3750G

                   I have 2 switch 370 in stack. Random the switch is operational, but is impossible connect to switch in ssh or telnet

Everyone's tags (2)
15 REPLIES
New Member

Switch WS-C3750G

What type of error are you getting, while trying to telnet or ssh ? Can you post the output?

Regards,
Chandu

Regards, Chandu
New Member

Re: Switch WS-C3750G

            I have configured switch to log information message to syslog, but there isn't message of error. When i try to connect to switch i receive connestion refused. I try to analyze the switch with nmap but there isn't open port tcp on 22 or 23. The switch is operational but for my is impossible establish a connection.

New Member

Switch WS-C3750G

Are you getting like the below one?

telent.PNG

Regards,
Chandu

Regards, Chandu
New Member

Switch WS-C3750G

My answer is :

sfwus01p:/var/lib/tftpboot# telnet 192.168.0.17

Trying 192.168.0.17...

telnet: Unable to connect to remote host: Connection refused

The only solution is reboot hardware (unplugged electrical cable and plugged electrical cable). I think to upgrade my IOS version, if there isn't none solution.

New Member

Switch WS-C3750G

Can you post a ping and traceroute to the device your tyring to telnet ...from

sfwus01p:/var/lib/tftpboot#  ?

Regards,
Chandu

Regards, Chandu
New Member

Switch WS-C3750G

sfwus01p:/var/lib/tftpboot# ping 192.168.0.17

PING 192.168.0.17 (192.168.0.17) 56(84) bytes of data.

64 bytes from 192.168.0.17: icmp_seq=1 ttl=255 time=0.479 ms

64 bytes from 192.168.0.17: icmp_seq=2 ttl=255 time=0.472 ms

64 bytes from 192.168.0.17: icmp_seq=3 ttl=255 time=2.21 ms

64 bytes from 192.168.0.17: icmp_seq=4 ttl=255 time=9.60 ms

^C

--- 192.168.0.17 ping statistics ---

4 packets transmitted, 4 received, 0% packet loss, time 3003ms

rtt min/avg/max/mdev = 0.472/3.193/9.609/3.771 ms

sfwus01p:/var/lib/tftpboot# traceroute 192.168.0.17

traceroute to 192.168.0.17 (192.168.0.17), 30 hops max, 40 byte packets

1  192.168.0.17 (192.168.0.17)  0.516 ms * *

sfwus01p:/var/lib/tftpboot#

Cisco Employee

Switch WS-C3750G

As you mentioned, if you have these already configured, you might be hitting a cosmetic bug. What is the IOS version your are running? I would try to upload a new one on the stack and see if that resolves the issue.

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00804799d7.shtml

Cisco Employee

Switch WS-C3750G

Walter, Please can we have a loo at your switch configs? Would it be possible for your paste it here if you have old one handy or if you could console and get it for us. I seems like you dont have telnet or SSH configured on the boxes.

Cheers,

-amit singh

New Member

Switch WS-C3750G

The version of Cisco IOS is 12.2(44) SE.Here my configuration for authentication :

aaa new-model

!

!

aaa authentication login default local group tacacs+ none

aaa authentication login Console local enable

aaa authorization exec default local group tacacs+

aaa authorization commands 15 default local group tacacs+

aaa authorization commands 15 Console if-authenticated

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting network default start-stop group tacacs+

aaa accounting connection default start-stop group tacacs+

aaa accounting system default start-stop group tacacs+

tacacs-server host 172.16.0.5 key 7

tacacs-server host 172.16.0.6 key 7

tacacs-server host 172.16.0.7 key 7

tacacs-server directed-request

line con 0

password 7

line vty 0 4

transport preferred ssh

line vty 5 15

transport preferred ssh

Hall of Fame Super Gold

Switch WS-C3750G

telnet: Unable to connect to remote host: Connection refused

The only solution is reboot hardware (unplugged electrical cable and plugged electrical cable). I think to upgrade my IOS version, if there isn't none solution.

Ok, console into the switch.  Post the following command outputs:

1.  sh version;

2.  sh proc cpu | ex 0.00

New Member

Switch WS-C3750G

It's strange. If i connected the console to switch 2 the message is "Low memory" and i can't connect. If i connected the console to switch 1 there isn't message, but i don't have a prompt for login. The switch are monitored by mrtg and mrtg visualize the following data :

MaxAverageCurrent
Used77.0 MRAM (30.1%)77.0 MRAM (30.1%) 77.0 MRAM (30.1%)
Free2093.3 kRAM (0.8%) 2080.4 kRAM (0.8%)

2081.3 kRAM (0.8%)

Hall of Fame Super Gold

Switch WS-C3750G

It's strange. If i connected the console to switch 2 the message is "Low memory" and i can't connect

Forget it.  This information is more than what I need. 

What IOS are you running?  When you console into an appliance and you're greeted with "Low memory" this is an indication that the IOS you're using is or has a CPU/Memory hog bug. 

New Member

Switch WS-C3750G

The version of IOS is 12.2(44)SE. I search on Internet if there is a memory upgrade for 3750, but the memory upgrade for switch start by 4000/4500 series. This stack is connected by 2 uplink to another stack switch of 3750 and by 2 uplink to another stack switch of 3750 (Total i have 3 stack switch of 3750 configured in spanning-tree environment). Also the another stack of 3750 switch has the same issue (after many week of switch up and running, i can't connect to the switch with telnet or ssh, i think for the same problem, low memory).All the stack switch have the same version of IOS.

The spannig-tree is configured in rapid-pvst mode with one stack primary for some vlan and another stack secondary for some vlan.

For now i can't upgrade IOS version of switches, which are the alternative solutions ?

Hall of Fame Super Gold

Switch WS-C3750G

Upgrade the IOS of your entire stack.  Go to 12.2(55)SE8 as it's more stable than what you are currently using.  It's more stable by A MILE!

New Member

Switch WS-C3750G

Walter, in your example you attempted a telnet yet your line VTY's have transport preferred SSH. If you want SSH to work, please also configure transport input SSH on the lines. Additionally, ensure you have cut the crypto keys for SSH. If you want telnet to also work, you will need to configure it under the lines.

523
Views
0
Helpful
15
Replies
CreatePlease to create content