Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Switches

Network Setup:

Cisco Router 2520 (2 Serial and 1 Ethernet)

S1: connected to csu/dsu goin to internet cloud. 172.16.101.10/30

E0: connected to 2924XL Switch's fa0/1

E0 of router is using a public IP (e.g. 172.16.16.1/27)

Objectives:

1. Implement 2 VLANs on the 2924 switch

2. Implement NAT on the Router.

Questions:

1. Is it possible to implement NAT in this kind of network setup?

2. If yes, Can i use the serial 1 as the nat outside and use the e0 as the nat inside.

3. All workstation on connected to the switch is using 192.168.111.0/24, and must go thru to the internet

8 REPLIES

Re: Switches

Hi,

A1: yes you can use NAT in this setup.

A2: yes typically you will use Serial1 as nat outside and E0 as nat inside

A3: If your hosts are on 192.168.111.0/24 then your routers E0 has to get an IP in this network. The config could look like this:

interface Serial1

ip address 172.16.101.10 255.255.255.252

ip nat outside

interface Ethernet0

ip address 192.168.111.1 255.255.255.0

ip nat inside

ip nat inside source list 1 interface Serial1 overload

access-list 1 permit any

One more question/remark: 172.16.16.1/27 is not an official IP subnet routed in the internet. In fact none of the IP addresses in your post are official IPs. Did you change the IPs in the post for security reasons? If not, then using NAT on the router might not help you.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Switches

yes i did change the IP's for security reasons. Another questions. My ISP gave me a Public IP block e.g. 10.10.10.0/27. Can I still use it?

Re: Switches

Hi,

Yes you can use your official IPs.

Depending on the number of hosts you have, you could use an officil IP on each of them. Then no NAT would be required, but security will be a concern.

Instead you could use some of the official IPs for servers (like email, Web etc.) and some for a NAT pool and private IPs on the hosts.

Regards, Martin

New Member

Re: Switches

How can i able to do this, if my e0 is a private ip?

My previous setup was e0 is a public ip, so my server's gateway is the e0's ip. Since i'm using NAT, e0 would be private. if i use the public ip what gateway i should use? it is not possible to use the s0 ip because its on /30 subnet. my public ip is /27, so the gateway must be on the same block. right? can you give a sample config, on how am i going to do this? Take note i'm using a 2520 router with only 2 serial and 1 ethernet interface and a 2924 switch.

Here is my NAT config its now working..

ip nat inside source list 10 interface Serial1 overload

interface Ethernet0

ip address 192.168.111.1 255.255.255.0

ip nat inside

!

interface Serial1

ip address 172.16.101.10 255.255.255.252

ip nat outside

!

access-list 10 permit 192.168.111.0 0.0.0.255

old setup w/o NAT

interface Ethernet0

ip address 172.168.111.1 255.255.255.224

!

interface Serial1

ip address 172.16.101.10 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 172.16.101.11

Re: Switches

Hello,

you could use secondary IPs:

interface Ethernet0

ip address 192.168.111.1 255.255.255.0

ip address 1.1.1.1 255.255.255.224 secondary

This way you can use two subnets within one VLAN.

Regards, Martin

New Member

Re: Switches

ok i got it. Thanks, one more question... since i implement this setup. my router seems to restart. and i got an error "System restarted by bus error at PC 0x3500664, address 0x38143269" what does it mean.Are there any draw back with 2 ip in one VLAN.

Re: Switches

HI friend,

The system encounters a bus error when the processor tries to access a memory location that either does not exist (a software error) or does not respond properly (a hardware problem).

check this link for Bus error problems

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_tech_note09186a00800cdd51.shtml

The config has no problems in your setup. Some routing protocols does not work well with secondary ip address.

HTH, rate if it does

Narayan

Re: Switches

This will not be caused due to 2 IPs. System restart due to bus error is generally due to bug in IOS.

can u paste show version of the router for further diagnosis.

pls rate if it helps ...

178
Views
0
Helpful
8
Replies
CreatePlease to create content