Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

switchover time etherchannel

Hello ,

We have 2 Cat6509 switches witch are connected by an etherchannel.

When one port / link in the etherchannel is disconnected it takes 500 milisec to 1 sec

before the session is switched over to the other link in the etherchannel.

The requirments are 200 msec.

Can anyone tell me if that is possible between 2 Cisco 6509E?

6 REPLIES
Hall of Fame Super Bronze

Re: switchover time etherchannel

The session is load-balanced amongst link members of the same etherchannel so there isn't any delay.

Are you talking about having multiple etherchannel bundles and if one etherchannel bundle fails, you want to speed up the process for the other etherchannel bundle to take over?

Can you post the portion of the config in question?

HTH,

__

Edison.

New Member

Re: switchover time etherchannel

hello Edison,

In the attachment you can see a drawing of the test i've build. I simulate traffic with an Acterna tester on both sides (this is onlu one session). Between the two 6509's is a port-channel with 2x 1GE.

When i send traffic both the links are used. On Cisco_6509_1 there's output on Gi2/1 en on

Cisco_6509_1 there's output on Gi1/2. When i force a link break the switchover time is between the 500ms en 1s. When i put back the fiber i can see that it only takes about 20ms.

regards,

Pascal

this is a part of the config from the two switches:

-------------------

switch1

interface GigabitEthernet1/1

description to g2/1 other

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 600

switchport mode trunk

mtu 1528

load-interval 30

speed nonegotiate

no snmp trap link-status

lacp rate fast

channel-group 1 mode active

interface GigabitEthernet1/2

description to g2/2 other

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 600

switchport mode trunk

mtu 1528

load-interval 30

speed nonegotiate

no snmp trap link-status

lacp rate fast

channel-group 1 mode active

interface Port-channel1

description Port-channel to other 6509

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 600

switchport mode trunk

mtu 1528

load-interval 30

speed nonegotiate

lacp fast-switchover

interface GigabitEthernet1/24

description to Acterna

switchport

switchport access vlan 600

switchport mode dot1q-tunnel

mtu 1528

load-interval 30

no cdp enable

-------------

switch2

interface GigabitEthernet2/1

description to g1/1 other

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 600

switchport mode trunk

mtu 1528

load-interval 30

speed nonegotiate

no snmp trap link-status

lacp rate fast

channel-group 1 mode active

interface GigabitEthernet2/2

description to g1/2 other

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 600

switchport mode trunk

mtu 1528

load-interval 30

speed nonegotiate

no snmp trap link-status

lacp rate fast

channel-group 1 mode active

interface Port-channel1

description Port-channel to other 6509

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 600

switchport mode trunk

mtu 1528

load-interval 30

speed nonegotiate

lacp fast-switchover

interface GigabitEthernet4/24

description to Acterna

switchport

switchport access vlan 600

switchport mode dot1q-tunnel

mtu 1528

load-interval 30

no cdp enable

------------------

Hall of Fame Super Bronze

Re: switchover time etherchannel

Try changing the etherchannel mode from active/active to on/on. It does speed up the convergence.

HTH,

__

Edison.

New Member

Re: switchover time etherchannel

when i switch to mode on, the channel is using PAGP and i want to use LACP. I also used the command channel-protocol LACP, but then the switch gives an error that its using PAGP.

(I want to use LACP because in the future i want to connect to an Alcatel switch)

Any other ideas?

kind regards,

Pascal

Hall of Fame Super Bronze

Re: switchover time etherchannel

"On" uses unconditional etherchanneling. It does not use any intelligence such as PAgP or LACP.

Intelligent mechanism provided by PAgP and LACP does create a delay when forming an etherchannel. Your requirement demand faster convergence, therefore "On" should be your choice.

Don't use the channel-protocol command when configuring etherchanneling. Let the mode dictate the type of etherchannel you are going to configure.

active/active = LACP

active/passive = LACP

desirable/desirable = PAgP

desirable/auto = PAgP

on/on = unconditional

HTH,

__

Edison.

Re: switchover time etherchannel

Edison is right that the fastest should be On/On. There is no channel negotiation to wait for. However, the negotiation should not cause you a problem. If the link is joining a channel it should not forward until any negotiation is complete anyway, so you will not notice any convergence problem. If the link is leaving a channel by failing, then it will not be able to negotiate anything anyway.

I wonder if you problem is not related to the ether-channel, but more related to the time it takes for the lower layers to detect and report the link failure. I wonder if there is a way to speed that up.

BTW, how are you measuring the convergence time? Is your measurment really measuring what you think it is measuring? Sorry, I know you posted a diagram, but I don't have Visio here.

Kevin Dorrell

Luxembourg

1594
Views
5
Helpful
6
Replies
CreatePlease to create content