Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Switchport Access Vlan command on a trunk port

To all,

During our data center switch configuration cleanup process I noticed that the following trunk interface configuration has the ”switchport access vlan 32" command configured on the port as well. Besides that fact that it makes the interface configuration look sloppy, are there any adverse effects that can occur do to this configuration error? Thank you!

interface GigabitEthernet4/13

switchport

switchport access vlan 32

switchport trunk encapsulation dot1q

switchport trunk native vlan 194

switchport trunk allowed vlan 8-12,17,28,30,32,36,40,42,46,60,62,66,80,88,96

switchport trunk allowed vlan add 100,110,112,127-131,194,195,212

switchport mode trunk

switchport nonegotiate

load-interval 30

shutdown

speed 1000

duplex full

spanning-tree portfast trunk

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Switchport Access Vlan command on a trunk port

Hello,

     It should not be there because you intend to use it as a trunk port. However, it won't take any effect because you had "switchport mode" to tell it what mode it should be. In your case the mode is trunk.

HTH,

Toshi

2 REPLIES

Re: Switchport Access Vlan command on a trunk port

Hello,

     It should not be there because you intend to use it as a trunk port. However, it won't take any effect because you had "switchport mode" to tell it what mode it should be. In your case the mode is trunk.

HTH,

Toshi

New Member

Re: Switchport Access Vlan command on a trunk port

Thank you!

6008
Views
0
Helpful
2
Replies
CreatePlease to create content