Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Switchport configuration

(WS-C3550-24-EMI)

interface GigabitEthernet0/1

switchport access vlan 20

switchport mode dynamic desirable

spanning-tree portfast

end

interface Vlan20

ip address 168.X.X.13 255.255.0.0

no ip redirects

standby 20 ip 168.X.X.14

standby 20 timers 1 4

standby 20 preempt

end

(WS-C3750G-24T-S)

interface GigabitEthernet1/0/11

switchport access vlan 101

switchport mode access

no ip address

duplex full

speed 1000

spanning-tree portfast

interface Vlan101

ip address 168.X.X.101 255.255.0.0

!

Hi all,

WS-C355024-EMI is connected to WS-C3750G-24T-S as uplink with the respective port shown above.

The C3750 is the distribution switch for server and C3550 is the Core swicth that do inter vlan routing.

I wonder why this 2 switch still can talk to each other although the individual port is accessing diffrent VLAN.

Please help. Thank you.

Regards,

Steve

5 REPLIES

Re: Switchport configuration

Hello Steve,

which IP addresses are you using for your Vlan 20 and 101 ? From what you have posted, it looks like they are both in the same 168.X network, can you verify that ?

Regards,

GNT

New Member

Re: Switchport configuration

Hi,

Yes both int vlan are using the same 168.0.0.X netowork.

My concern is how come this still work although 2 ports are accessing diffent VLAN.

THANK YOU

New Member

Re: Switchport configuration

Hi,

I beleive that this is because of "switchport mode access" command on the second switch.

Trunk negotiation fails so both ports are actually in access mode. Packets are not marked with VLAN tag so when 3550 receives packet on its port it beleives that packet belongs to VLAN 20 and sends it further in VLAN 20.

//Mikhail Galiulin

New Member

Re: Switchport configuration

Is it common to configure the port in this way?

New Member

Re: Switchport configuration

Steve,

Mikhail is correct. The switchport mode access command tells the port to not VLAN tag the packets as they pass through. The switchport mode trunk command would tag the packets with the VLAN ID which would cause them to be discarded at the other interface.

Hope this helps,

Mike

274
Views
3
Helpful
5
Replies