Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Switchport configured full duplex, but working on half

Hello,

I have encountered a strange issue I have never seen before.

I have a 2811 router Fa0/0 interface connected directly to a C3750E gigabit switchport with a normal UTP patchcable.

Both sides are configured with speed 100, duplex full, but the switchport operational status is 100Mbps, Half-duplex.

Any ideas on what might cause this situation?

This is the switchport configuration:

0001#sh run int Gi1/0/44

Building configuration...

!

interface GigabitEthernet1/0/44

switchport access vlan 102

switchport mode access

speed 100

duplex full

no snmp trap link-status

spanning-tree bpduguard disable

end

This is the port operational status:
0001#sh int Gi1/0/44 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/0/44                     connected    102          half    100 10/100/1000BaseTX

1 REPLY
Cisco Employee

Re: Switchport configured full duplex, but working on half

Hello,

When both end hardware are different with different capabilities, it is better to set the speed/duplex to auto so that the two devices negotiate speed/duplex along with few other physical layer parameters.Here is a valid configuration table:

http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af0.shtml#auto_neg_valid

Here is a link that explains the reasons for enabling auto negotiation:

http://www.dell.com/content/topics/global.aspx/power/en/ps1q01_hernan?c=us&cs=555&l=en&s=biz

Hope this helps.

Regards,

NT

857
Views
0
Helpful
1
Replies
CreatePlease to create content