Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Switchport trunk allowed vlan add statement listed in interface config

Hi

I have a 6509 running 12.2(33)SXI4 that has an interface config that I have never seen before:

interface TenGigabitEthernet3/2

description hv Sw-2-1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 308

switchport trunk allowed vlan 1,200,203,206,308,310,318,322,330,340,341,370

switchport trunk allowed vlan add 701

switchport mode trunk

switchport nonegotiate

load-interval 30

spanning-tree bpduguard disable

spanning-tree guard root

end

I have never seen the vlan add statement listed in the interface config.  Why did it not simply add it to the list of allowed vlans?  This is on 4 interfaces that are configured the same.

Thanks

-Doug

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Switchport trunk allowed vlan add statement listed in interface

Doug

I wonder when you added vlan 322 to the list whether the switch moved 370 from the first line down to the "add" line? Can you tell us that?

I have seen this behavior (putting some vlan entries onto a vlan add line) on some switches but can not remember whether they were 6500 or not. Like Jon I assumed that it was a limitation on how long a single line can be.

HTH

Rick

8 REPLIES
Hall of Fame Super Blue

Switchport trunk allowed vlan add statement listed in interface

Doug

I wonder if it is just a limitation in terms of the length of a line in the config ie. to add the extra vlan would take the original line past the limit so a new line entry is used.

As long as "sh int trunk" shows all allowed vlans on the trunk i don't think it is an issue.

Jon

New Member

Switchport trunk allowed vlan add statement listed in interface

I considered that, but I added vlan 322 this morning and it placed it in the list.

701 is shown in the trunk when I do a sh int trunk.

Hall of Fame Super Blue

Switchport trunk allowed vlan add statement listed in interface

Doug

No idea then unless for some reason it splits up the vlan ranges and needs separate lines for those ranges but i haven't come across this before on 6500s.

Like i say, as long as it on the trunk link i don;t think it matters but it would be interesting to hear if anyone else knows the exact reason.

Jon

Hall of Fame Super Silver

Switchport trunk allowed vlan add statement listed in interface

Doug

I wonder when you added vlan 322 to the list whether the switch moved 370 from the first line down to the "add" line? Can you tell us that?

I have seen this behavior (putting some vlan entries onto a vlan add line) on some switches but can not remember whether they were 6500 or not. Like Jon I assumed that it was a limitation on how long a single line can be.

HTH

Rick

New Member

Switchport trunk allowed vlan add statement listed in interface

That looks like the right answer.  I checked last night's backup and all vlans were in a single list.

Thanks for the suggestion.

Re: Switchport trunk allowed vlan add statement listed in interf

If you need to add any more VLAN's to the already allowed list you need to use the add command otherwise you will override what is in there already.

So if you have for example:

switchport trunk allowed vlan 1,200,203,206,308,310,318,322,330,340,341,370

And all is working.  Lets say you add another VLAN 701 and want that VLAN added to this list as well.  Now if you do

switchport trunk allowed vlan 701

You will override that list and only 701 will be allowed

So you have to do:

sw trunk allowed vlan add 701

And that is what you are seeing.

Hall of Fame Super Blue

Switchport trunk allowed vlan add statement listed in interface

Mohammed

Agreed, but that is not the issue here. It is why has the switch used a second line in the config when it could have simply added the vlan to the existing line

Jon

Re: Switchport trunk allowed vlan add statement listed in interf

Ah gotcha well in that case what you said above is right.  I believe after like 12 13th one will go on the next line.

1034
Views
0
Helpful
8
Replies