Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

switchport trunk allowed vlan remove 1607

Hi

I have a basic trunk

int gx/x

sw trunk encap dot1q

sw tr native vlan 111

sw mo tr

I applied the command

switchport trunk allowed vlan remove 1607

and the IOS removed all the vlans from the trunk.Is it normal ?

Regs

Kas

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: switchport trunk allowed vlan remove 1607

No, its not normal and I'm not sure what you are doing wrong. You need to post more information.

I just tested here and it works as advertised on a 3560 switch:

Port        Vlans allowed on trunk
Fa0/19      1-4094

Port        Vlans allowed and active in management domain
Fa0/19      1,13,112,200,222

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/19      1,13,112,200,222

Rack1SW4(config)#int f0/19
Rack1SW4(config-if)#sw tru allowed vlan remove 13
Rack1SW4(config-if)#end


Rack1SW4#sh run int f0/19
Building configuration...

Current configuration : 113 bytes
!
interface FastEthernet0/19
switchport trunk allowed vlan 1-12,14-4094
switchport mode dynamic desirable


Port        Vlans allowed on trunk
Fa0/19      1-12,14-4094


Port        Vlans allowed and active in management domain
Fa0/19      1,112,200,222

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/19      1,112,200,222

Regards,

Edison

3 REPLIES
Hall of Fame Super Bronze

Re: switchport trunk allowed vlan remove 1607

No, its not normal and I'm not sure what you are doing wrong. You need to post more information.

I just tested here and it works as advertised on a 3560 switch:

Port        Vlans allowed on trunk
Fa0/19      1-4094

Port        Vlans allowed and active in management domain
Fa0/19      1,13,112,200,222

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/19      1,13,112,200,222

Rack1SW4(config)#int f0/19
Rack1SW4(config-if)#sw tru allowed vlan remove 13
Rack1SW4(config-if)#end


Rack1SW4#sh run int f0/19
Building configuration...

Current configuration : 113 bytes
!
interface FastEthernet0/19
switchport trunk allowed vlan 1-12,14-4094
switchport mode dynamic desirable


Port        Vlans allowed on trunk
Fa0/19      1-12,14-4094


Port        Vlans allowed and active in management domain
Fa0/19      1,112,200,222

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/19      1,112,200,222

Regards,

Edison

Community Member

Re: switchport trunk allowed vlan remove 1607

Hi edison,

Thanks for your reply.

I have attached truncated configuration of the switch taken on the 23rd June. Kindly note the configuration of G1/0/1. Today under this interface I had only applied the switchport trunk allowed vlan remove 1607.

What happened next was all vlans of that port vanished and whatever L3 device we had over that port  communication went down as VLANS were not accessible.

I am not sure what went wrong ..Later i found that it was allowing the vlan 1607 and i had to revert back the original plain trunk configuration.

Hall of Fame Super Bronze

Re: switchport trunk allowed vlan remove 1607

I don't see any manual pruning on the file that was attached:

interface GigabitEthernet1/0/1
description trunk to ----Gi0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 970
switchport mode trunk
speed 1000
duplex full
srr-queue bandwidth share 1 50 50 50
srr-queue bandwidth shape  3  0  0  0
priority-queue out
mls qos trust dscp

Perhaps the command was typed incorrectly. As I said, the command as indicated should work as advertised. An incorrect syntax can cause adverse effects.

Regards,

Edison

7380
Views
0
Helpful
3
Replies
CreatePlease to create content