Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

switchport trunk vlan allowed not workink

I have trunk port between two swithes, bot are in same vtp domain, and I cannot put switchport trunk allowed vlan command on port. After commande there is no this command in config, and when I look at port with sh int x/x trunk, also nothing changed

1 ACCEPTED SOLUTION

Accepted Solutions

Re: switchport trunk vlan allowed not workink

don't add the vlan, allow it only if it is the 1st one and only one on the trunk. after that u can use the "add "

Switch(config-if)#switchport trunk allowed vlan 99

HTH

Sam

7 REPLIES

Re: switchport trunk vlan allowed not workink

not knowing which platform or release, hard to tell if there is a know issue.

anyways, is port configured as switchport and trunk encapsulation set ?

Sam

Community Member

Re: switchport trunk vlan allowed not workink

3560, ipbase 12.25. Ports are configured as trunks and enc is set and ports are trunking fine

Re: switchport trunk vlan allowed not workink

Normally this works. Could you show us an example please? For example, a terminal session with:

- the show run int before the change,

- the command to do the change,

- the show run int after the change.

Kevin Dorrell

Luxembourg

Community Member

Re: switchport trunk vlan allowed not workink

here it is

sh runn int g0/1

Building configuration...

Current configuration : 231 bytes

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

end

#conf te

Enter configuration commands, one per line. End with CNTL/Z.

(config)#int g0/1

(config-if)#switch trunk all

(config-if)#switch trunk allowed vlan add 99

(config-if)#end

#conf tesh runn int g0/1

Building configuration...

Current configuration : 231 bytes

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

end

#

Re: switchport trunk vlan allowed not workink

don't add the vlan, allow it only if it is the 1st one and only one on the trunk. after that u can use the "add "

Switch(config-if)#switchport trunk allowed vlan 99

HTH

Sam

Community Member

Re: switchport trunk vlan allowed not workink

:-))), thanks

Re: switchport trunk vlan allowed not workink

below on 3560 / C3560-ADVIPSERVICESK

Switch(config-if)#switchport trunk allowed vlan 210

Switch#sh run

!

interface FastEthernet0/2

switchport trunk allowed vlan 210

168
Views
0
Helpful
7
Replies
CreatePlease to create content