Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Switchport trunks on end devices/ switchport trunk native.

All, I have this config I inherited: To me, this config looks out of wack. These ports are end user ports for some machines we have on the shop floor. Their are no phone attached to the ports configured as below. I do plan on removing the qos, and srr-queue commands. My question is, what is the point of the switchport trunk commands? Are end user ports to be trunked?

What does the Switchport trunk native, do for me?

VLAN 205 is a bogus VLAN. Is it needed?

THANK YOU FOR YOUR HELP.

interface FastEthernet1/0/3

switchport access vlan 200

switchport trunk encapsulation dot1q

switchport trunk native vlan 205

switchport mode dynamic desirable

switchport voice vlan 246

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

2 REPLIES
Cisco Employee

Re: Switchport trunks on end devices/ switchport trunk native.

Hi Friend,

You can remove all trunk related commands if you are sure this ports if for end user host. Also change "switchport mode dynamic desirable" to "switchport mode access".

Sometimes even when servers are connected on switchport they understand dot1q tags and is the reason switchport may be configured for trunk but as you mentioned they are user ports you can simply remove trunk configuration.

HTH

Ankur

*Pls rate all helpfull post

Cisco Employee

Re: Switchport trunks on end devices/ switchport trunk native.

Hello Rob,

As you have mentioned the role of the ports and devices connected to it, the above configuration can be stripped down to basic configuration.

interface FastEthernet1/0/3

switchport access vlan XX

spanning-tree portfast

====

Regarding your questions on switchport trunk,

a port has to be configured as trunk when it has to carry multiple vlan traffic and to differentiate traffic we define encapsulation method.

Trunk native is used to identify the vlan traffic for which frames will not be tagged/encapsulated.

HTH

Padmanabhan

372
Views
0
Helpful
2
Replies
CreatePlease to create content