Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Tagged vlan on Catalyst 3750

Could someone please tell me how to tag a physical port to multiple vlans on Cisco switch.

Eg :

There are 5 vlans with id 10,20,30,40,50 I need to tag port 1 to above listed valns. What are the set of commands do I need to execute. Thanx in advance !!

4 REPLIES

Re: Tagged vlan on Catalyst 3750

Hi Pradeep,

On port 1 do like

conf t

interface fa 0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no shut

By default on Cisco switches vlan1 is native vlan and the Vlan 1 traffic is not tagged. If you want to tag the Vlan 1 traffic also then you have to use a global config command " vlan dot1q tag all".

HTH, Please rate if it does.

-amit singh

New Member

Re: Tagged vlan on Catalyst 3750

Hi Amit,

Thax for the reply. What am trying to do in not just create a tagged port. I want to pag a physical port to multiple vlans. What I mean, would like port 1 to be member of vlan10, vlan20,vlan30 ...

I tried the following thing :

config t

interface gig0/1

switchport access vlan 10

switchport access vlan 20

.

.

switchport access vlan 50

end

But when I do show vlan I could see port 1 is only member of last vlan in the sequence i.e vlan50.

-pradeep

Silver

Re: Tagged vlan on Catalyst 3750

Hi Pradeep ,

configure the gig0/1 like this.

int g0/1

switchport mode trunk

switchport trunk encapsulation dot1q

switchport nonegotiate

switchport trunk native vlan 1

switchport trunk allowed vlan add 10,20,30,40,50.

Check the show vlan output.

Hope it helps you.

Thanks,

satish

Purple

Re: Tagged vlan on Catalyst 3750

you cannot make a "access port" in multiple vlans . You can make the port a trunk to carry multiple vlans . The only way i could think of doing this would be create a layer 3 SVI with multiple secondary addresses and assign that port into the vlan . If the device on the port needs to be in multiple vlans it would have to be able to trunk .

4405
Views
0
Helpful
4
Replies
CreatePlease to create content