Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Topology change from a portfast interface

Hi all,

Recently, I had a topology change in my network enviroment comming from a switchport access port.
This port is configured with spanning-tree portfast command.

I assume that a switch never generates a TCN when a port configured for portfast goes up or down.

Switch says: Number of topology changes 212 last change occurred 07:37:33 ago from GigabitEthernet0/33

My switch port:

interface GigabitEthernet0/33

switchport access vlan 18

switchport mode access

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust cos

no snmp trap link-status

auto qos voip trust

spanning-tree portfast

Is that a normal behavior? What can be a possible issue?

Thank you

Everyone's tags (1)
8 REPLIES
Purple

Topology change from a portfast interface

Hi,

you're correct a Portfast port will not send any TCN but did you verify you port is indeed in Portfast mode ?

Show spanning-tree interface g0/33 will tell you so.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Topology change from a portfast interface

Here bellow:

#sh spanning-tree interface gigabitEthernet 0/33

Vlan             Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0060         Desg FWD 4         128.34   Edge P2p

#sh run interface gigabitEthernet 0/33

interface GigabitEthernet0/33

switchport access vlan 18

switchport mode access

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust cos

no snmp trap link-status

auto qos voip trust

spanning-tree portfast

Purple

Topology change from a portfast interface

Hi,

the correct syntax was sh spanning-tree interface g0/33 portfast.

Sorry for the error.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Topology change from a portfast interface

Hi,

it's enabled

#sh spanning-tree interface gigabitEthernet 0/33 portfast

VLAN0060         enabled

VIP Purple

Topology change from a portfast interface

Hi tdrumond,

are you running Rapid PVST ??

which swiitch ??

may be its a bug :

I has been detected on Cat3550 as CSCeb48939 .

Regards

Please rate if it helps.

New Member

Topology change from a portfast interface

Hi sandeepchoudhary21

I'm using a 3560:

Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(35)SE5, RELEASE SOFTWARE (fc1)

and

spanning-tree mode pvst

Re: Topology change from a portfast interface

Hi there,

disable the DTP with switchport none and let me know pls. Hardcode the speed and the duplex mode too.

Take Care

Alessio

New Member

Re: Topology change from a portfast interface

Ok, now it's off, but I need some time to get results

868
Views
0
Helpful
8
Replies