Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Traffic engineering

Hi.I have following questuon.

the subnet to which host belongs, connected to a 7507 router and host at other end belongs to other subnet which is connected to 2811 Cisco router's interface.There is 2Mbps point-to-point connection between two routers.I would like to segment the 2Mbps bandwidth so that particular host in both subnets should get the more bandwidth than others.Say the following topology:

Subnet: 192.168.1.0/24,host 192.168.1.2,gateway(router) 192.168.0.1 <<-----2Mbps Connection--->>Subnet 192.168.2.0/24,host 192.168.2.2,gateway(router):192.168.2.1, there are also other hosts in both subnets.I want to segment the bandwidth so that host 192.168.1.2 and 192.168.2.2 should get at least 128Kbps bandwidth , and others will get the remaining bandwidth..Is it possible to do , if yest then on which network device, either on router at both ends or hosts ate both end ???

Regards,

-Sanjeev

Network and Security Admin

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Traffic engineering

Hello Sanjeev,

you can use QoS on both routers.

access-list 101 permit ip host 192.168.1.2 host 192.168.2.2

class-map selectedflow

match access-group 101

policy-map myscheduler

class selectedflow

bandwidth 128

class class-default

fair-queue

int serx/y

service-policy out myscheduler

on the other end you need a different ACL with hosts in reverted order.

access-list 102 permit ip host 192.168.2.2 host 192.168.1.2

all the rest is the same but needs to be configured on both routers.

Hope to help

Giuseppe

3 REPLIES
Hall of Fame Super Silver

Re: Traffic engineering

Hello Sanjeev,

you can use QoS on both routers.

access-list 101 permit ip host 192.168.1.2 host 192.168.2.2

class-map selectedflow

match access-group 101

policy-map myscheduler

class selectedflow

bandwidth 128

class class-default

fair-queue

int serx/y

service-policy out myscheduler

on the other end you need a different ACL with hosts in reverted order.

access-list 102 permit ip host 192.168.2.2 host 192.168.1.2

all the rest is the same but needs to be configured on both routers.

Hope to help

Giuseppe

Community Member

Re: Traffic engineering

Hi.thank you very much for the reply.

What I understand it will restrict bandwidth for both end-hosts.But I want at least 128Kbps or more from 2Mbps for both end hosts,or if available they can get more than 128Kbps, because that is also used by other hosts in subnets,If less users are using it and 2Mbps bandwidth is free then they can use more than 128Kbps.But they should get at least 128Kbps.And that 128Kbps bandwidth dedicated to end hosts will not be disturbed by other hosts.I hope you are getting my question.

thanks again,waiting for reply.

Hall of Fame Super Silver

Re: Traffic engineering

Hello Sanjeev,

bandiwidth command in CBWFQ provides the mininum bw for the class when the link is full.

but the mechanism is elastic and does not include a rate limiting action: if there are free resources on link the class can use more then 128 kbps.

so it should fit your needs

Hope to help

Giuseppe

112
Views
5
Helpful
3
Replies
CreatePlease to create content