Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Traffic is not distributed properly through each link in etherchannel.

Dear Team,

Can you any have any idea on below.

I have 3560 cisco switch and created port-channel and assign the two port to Po1 switch is connected to HP VC.

The issue is only one port is highly utilizing and on other port no traffic is there.

Plz find below config for your reference.

Cisco 3560

Switch1#sh etherchannel su

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 4

Number of aggregators:           4

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         LACP      Gi0/28(P)   Gi0/30(P)

2      Po2(SU)          -        Gi0/22(P)   Gi0/23(P)   Gi0/24(P)

                                 Gi0/25(P)   Gi0/26(P)   Gi0/27(P)

3      Po3(SU)          -        Gi0/6(P)    Gi0/7(P)    Gi0/8(P)

                                 Gi0/9(P)    Gi0/10(P)   Gi0/11(P)

4      Po4(SU)          -        Gi0/1(P)    Gi0/14(P)

Switch1#sh run int po1

Building configuration...

Current configuration : 166 bytes

!

interface Port-channel1

description HP VC

switchport trunk encapsulation dot1q

switchport trunk allowed vlanXXXX

switchport mode trunk

end

Switch1#sh run int g0/28

Building configuration...

Current configuration : 223 bytes

!

interface GigabitEthernet0/28

description HP VC server

switchport trunk encapsulation dot1q

switchport trunk allowed vlan XXXX

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

end

Switch1#sh run int g0/30

Building configuration...

Current configuration : 223 bytes

!

interface GigabitEthernet0/30

description HP VC server

switchport trunk encapsulation dot1q

switchport trunk allowed vlan XXXX

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

end

Switch1#

Regards,

Prasad

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

Re: Traffic is not distributed properly through each link in eth

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

 

If you're seeing a load imbalance TO the switch (i.e. from your server), then you need to see if your server has any load balancing options as the switch has no control over that.

If you're seeing load imbalance FROM the switch (i.e. to your server), then your need to select the best load balancing hash algorithm, for your traffic characteristics.  Often the switch's default is not the best.  Often using both source and destination IP addresses works well.

Realize sometimes the switch doesn't offer a good load balancing hash algorithm for your traffic.  For example, if most of your traffic was between two hosts (e.g. replication), all that traffic would take the same link.  (Note: a 6500 offers hash that includes port numbers for such situations, but 3K switches do not.)

This link http://www.cisco.com/c/en/us/support/docs/lan-switching/etherchannel/12023-4.html, explains your choices on different Cisco switches.

3 REPLIES
Silver

Traffic is not distributed properly through each link in etherch

What is HP VC server? What is it sending traffic to? And where from is it reciving traffic? Which hashing algorithm are you using? Can you show the interface counters.

Daniel Dib
CCIE #37149

Daniel Dib CCIE #37149 Please rate helpful posts.
New Member

Traffic is not distributed properly through each link in etherch

Dear Dani,

Thanks for your update and sorry for late reply,

We have HP blade server connected through (HP VC) and taking back up on blade servers through DP on Network base, and we are using default hashing algorithm.

Switch1#sh int counters

Port            InOctets    InUcastPkts    InMcastPkts    InBcastPkts

Gi0/1      4562927656484    66392875186        1847483              0

Gi0/2        13176542586       71713707              0          25531

Gi0/3         1900362462       13767303              0              0

Gi0/4         1509867072            261              0       23588493

Gi0/5         1890453212       13696932              0              0

Gi0/6     14544362704314    10480956031        1847117              0

Gi0/7     65538886024236    51305371079        1847117          46220

Gi0/8         4250911026       27430358        1847117         493967

Gi0/9         3278139491       21581493        1847117              0

Gi0/10     2239812209312     1668516659        1847117              0

Gi0/11       18977644290       40381156        1847117              0

Gi0/12        7106828728       40409414              0          21914

Gi0/13       60966452542      117821737              0          44747

Gi0/14     6658811930336    97266413481        1847483          76539

Gi0/15      660361512073     9558185434              0          26820

Gi0/16        4517384940       32731826              0            589

Gi0/17           6176748          37920              6          36600

Gi0/18       13170490194       72004734              0          16047

Gi0/19            399068            270              0             52

Gi0/20        1511299084            228              0       23608627

Gi0/21     4810427256500     4525067782         923248          72519

Port            InOctets    InUcastPkts    InMcastPkts    InBcastPkts

Gi0/22       45570313835      305457187        1847099          46240

Gi0/23      916003605666     2260702749        1847099          17829

Gi0/24    16654479345028    12407925561        1847099         143800

Gi0/25    86272576072349    64157011758        1847099              0

Gi0/26      664849496052     1058961267        1847099          17947

Gi0/27       64763004823      146421633        1847099          21143

Gi0/28    261920056168395   191200404985        1824999              0

Gi0/29        5725072524       41484456              0              0

Gi0/30    26329857235463    19046331944       38155322       55863157

Gi0/31        1172532292              0       12980893             92

Gi0/32        5284664422              0       16298718       38370336

Gi0/33         945391966        4272721         515272         366064

Super Bronze

Re: Traffic is not distributed properly through each link in eth

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

 

If you're seeing a load imbalance TO the switch (i.e. from your server), then you need to see if your server has any load balancing options as the switch has no control over that.

If you're seeing load imbalance FROM the switch (i.e. to your server), then your need to select the best load balancing hash algorithm, for your traffic characteristics.  Often the switch's default is not the best.  Often using both source and destination IP addresses works well.

Realize sometimes the switch doesn't offer a good load balancing hash algorithm for your traffic.  For example, if most of your traffic was between two hosts (e.g. replication), all that traffic would take the same link.  (Note: a 6500 offers hash that includes port numbers for such situations, but 3K switches do not.)

This link http://www.cisco.com/c/en/us/support/docs/lan-switching/etherchannel/12023-4.html, explains your choices on different Cisco switches.

236
Views
0
Helpful
3
Replies
CreatePlease login to create content