Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Traffic limiting issue.

I have the following config on a Cisco router that is being used as a test lab for our server team. We are simulating some of our WAN connections.

interface GigabitEthernet0/12

switchport access vlan 50

switchport mode access

speed 10

duplex full

srr-queue bandwidth limit 10

spanning-tree portfast

interface GigabitEthernet0/13

switchport access vlan 120

switchport mode access

speed 10

duplex full

srr-queue bandwidth limit 20

spanning-tree portfast

So port 13 is limited to 10% of the bandwidth and port 12 is limited to 30%

The issue I'm having is that if these two 'WAN Connections' were to transfer files between each other you would think that the speed would be of the slowest link, but that is not the case. If a computer on port 13 downloads from 12 it gets up to about 340KB, which is way more that port 12 should be able to handle

If computer on port 12 downloads from 13 then the max speed it gets is about 64KB, which is what i expect.

So is there a way to get this to act in a asymmetrical way and not a symmetrical way which it seems to be doing at the moment? i.e. if port 13 downloads from port 12 then speeds shouldn't go above 10% of the link....

thanks.

2 REPLIES
Hall of Fame Super Bronze

Re: Traffic limiting issue.

'srr-queue bandwidth limit' only provides an egress policer - if you want ingress and egress, you should look into MQC with the police command:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_50_se/configuration/guide/swqos.html#wp1322872

HTH,

__

Edison.

Super Bronze

Re: Traffic limiting issue.

"interface GigabitEthernet0/12

switchport access vlan 50

switchport mode access

speed 10

duplex full

srr-queue bandwidth limit 10

spanning-tree portfast

interface GigabitEthernet0/13

switchport access vlan 120

switchport mode access

speed 10

duplex full

srr-queue bandwidth limit 20

spanning-tree portfast

So port 13 is limited to 10% of the bandwidth and port 12 is limited to 30%"

Actually, you've defined port 13 limited to 20% (egress) and port 12 limited to 10% (egress). Also these values are not always exact.

"Usage Guidelines

If you configure this command to 80 percent, the port is idle 20 percent of the time. The line rate drops to 80 percent of the connected speed. These values are not exact because the hardware adjusts the line rate in increments of six. "

From: http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_50_se/command/reference/cli3.html#wp1947391

193
Views
4
Helpful
2
Replies
CreatePlease to create content