Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

traffic Shaping on 3560G

Hi,

I need help to implement the shapping VLAN only on the trunk link between the 6500 and 3560.

I want to reserve:

bandwidth for internet vlan (100mb / s) with a high priority

bandwidth for the MPLS vlan (10 mb / s) with a high priority

Config 3560:

mls qos
!
vlan internal allocation policy ascending
!
vlan 201

name MPLS

!

vlan 202

name internet
!

class-map match-all IP_TRAFFIC

match access-group 100

!

class-map match-all TRAFFIC_201
match vlan 201

!

class-map match-all TRAFFIC_202

match vlan 202

!
policy-map POLICE_10MO
class TRAFFIC_201

police 10000000 8000 exceed-action drop

!

policy-map POLICE_100MO

class TRAFFIC_202

police 100000000 8000 exceed-action drop

!

policy-map VLAN201_POLICY
class IP_TRAFFIC
set precedence 5
service-policy POLICE_10MO

!

policy-map VLAN202_POLICY
class IP_TRAFFIC
set precedence 4
service-policy POLICE_100MO
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
mls qos vlan-based
!
!
interface Vlan201
no ip address
service-policy input VLAN201_POLICY
!
interface Vlan202
no ip address
service-policy input VLAN202_POLICY
!

access-list 100 permit ip any any

!

end of configuration

Is this corect ? can we do otherwise? All solutions interest me

Thanks

8 REPLIES
Cisco Employee

traffic Shaping on 3560G

Hello,

Traffic shaping and policing are different QoS mechanisms. Shaping buffers or delays traffic in the queue when traffic exceeds a configured threshold. Policers either discard or remark traffic when it exceeds a configured threshold. If you intend to configure policing it can only be applied on a per port or per port/per vlan basis and in the ingress direction. This is similar to the configuration above expect that your child policy can only match on input interfaces.

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst3560/software/release/12.2_55_se/command/reference/cli1.html#wp11904066

Shaping can be configured on the ingress or egress queues. If your goal is to reserve bandwidth for different traffic classes I would mark on ingress and shape on egress. Or maybe per-port/per-vlan policing to your desired rate.

HTH,

Ryan

traffic Shaping on 3560G

Follow the steps in this documentation.

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND_40/QoSCampus_40.html#wp1099172

Here is the burst size formual, stick to this:

100MB = 100000000

12500000 = 100000000 / 8

Normal Burst size is for 100MB is: 18750000 = 12500000 X 1.5

Let me know the result.

New Member

traffic Shaping on 3560G

Hi

it's ok on 3760G, but i want to implement the same Shaping on the 6500 in the same Link.

The configuration is the same or not ?

Thanks

traffic Shaping on 3560G

Most likely yes.  Just copy the config and see, if syntax is being recognized by 6500. If it does, it will work on 6500 and then there is IOS version and feature difference as well. You should be familiar with them as well on 6500.

Thanks

Rizwan Rafeek

New Member

traffic Shaping on 3560G

Rizwan,

On 6500, it's not possible to match input interface.

They don't want match vlan and apply service-policy in interface vlan.

Thanks

New Member

Re: traffic Shaping on 3560G

Hi Ibellicaud,

do you want to shape traffic or do you want

to prioiritize traffic (queuing) or maybe both?

If you want to reserve bandwitdth for specific traffic you probably want to do some queuing

(in that case the configuration would look different thant that you posted).

Regards,

Michael

New Member

traffic Shaping on 3560G

Hi,

I want to reserve bandwith for specific vlan in port trunk between the 6500 and 3560,

regards,

Laurent

New Member

Re: traffic Shaping on 3560G

Hi,

this example configuration should guarantee you 30% bandwidth of the trunk for VLAN 10

and 40% for VLAN 100.

If you also want to limit (and not only guarantee) the bandwitdth you also need the policy statement.

I couldn't test this config in a lab so I don't know if it really does what ist should, but

you can give it a try...

PS Of course you have to have a similiar configuration on the 65000 (at least the trust cos statement)

--

! enable QoS globally

mls qos

! set trust boundary

interface Gigx/y

desc TRUNK INTERFACE TO 6500

mls qos trust cos

! classify traffic

class-map match-all VLAN10

match vlan 10

class-map match-all VLAN100

match vlan 100

policy-map TAG-VLAN10

class VLAN10

set cos 4 !default map to queue 4

police 10000000 20000 exceed-action drop !ONLY if you want to limit the traffic to 10Mbit/burst size 20KB

policy-map TAG-VLAN100

class VLAN100

set cos 3 !default map to buffer 3

police 100000000 100000 exceed-action drop !ONLY if you want to limit the traffic 100Mbit/burst size 100KB

interface Vlan 10

desc VLAN_INTERFACE

service-policy input TAG-VLAN10

interface Vlan 100

desc VLAN_INTERFACE

service-policy input TAG-VLAN100

interface Gigx/y

desc SWITCHPORT_INTERFACE

mls qos vlan-based

! Allocating buffer space in percent

mls qos queue-set output 1 buffers 15 15 30 40

! Allocating bandwidth in percent, queue 3 is guaranteed 30% and queue is guaranteed 40%

interface Gigx/y

desc TRUNK INTERFACE TO 6500

queue-set 1

ssr-queue bandwidth share 15 15 30 40

--

Regards,

Michael

1308
Views
0
Helpful
8
Replies