Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble routing vlans 3560

I have a 3560, typical setup with voice and data

interface GigabitEthernet0/6

switchport access vlan 200

switchport mode access

switchport voice vlan 100

spanning-tree portfast

Vlan 200 has an interface 192.168.2.1

Vlan 100 has an interface 192.168.1.1

But i cant get the two to route? What is the trick?

Thanks!

13 REPLIES
Cisco Employee

Re: Trouble routing vlans 3560

Hi Friend,

Can you check if "ip routing" is enabled? Can you post the output of "sh ip route"?

Regards,

Ankur

Re: Trouble routing vlans 3560

opps!

Yes, that command was added into the config.

Purple

Re: Trouble routing vlans 3560

Make sure you have created the layer 2 vlans , check with a "show vlan" command and those 2 should show in the list as active . Make sure your mask is correct on both layer 3 definitions and the clients have their default gateway pointing to the router address for the given vlan.

Re: Trouble routing vlans 3560

The vlans are created.

interface Vlan100

ip address 192.168.2.1 255.255.255.0

no ip route-cache

!

interface Vlan200

ip address 192.168.1.1 255.255.255.0

no ip route-cache

Should my gateways be the interface of the VLANs?

Hall of Fame Super Bronze

Re: Trouble routing vlans 3560

> Should my gateways be the interface of the VLANs?

Yes.

Can you ping workstations on each Vlan from the switch ?

Can we see a 'show ip route' from the switch ?

Re: Trouble routing vlans 3560

Sorry, not onsite.

So for PC 1 I have set

192.168.2.50

255.255.255.0

192.168.2.1 gateway

On PC 2

I have set 192.168.1.50

255.255.255.0

192.168.1.1 gateway

I cant ping either side, but at the switch, I can ping the interfaces of the VLANs. (havent tried the pcs)

Im offsite, but heading back shortly. It's really odd, because I thought the VLANS would automagically route between them if they were created on the switch.

Re: Trouble routing vlans 3560

If these are windows machines, please ensure that you have turned off the local firewall settings on them.

Narayan

Re: Trouble routing vlans 3560

Yep, cant ping them still. Im trying to verify that routing between the VLANs will work on this 3560, or do I need to have a separate router?? because I thought that the 3560's work as layer 3 switches and can route accordingly.

Hall of Fame Super Bronze

Re: Trouble routing vlans 3560

You don't need a separate router, please post the 'show ip route' from the switch.

Re: Trouble routing vlans 3560

Thanks Edison, I will do this when I get a chance.

If I took this out of the box and wanted to configure VLAN 100 and VLAN 200 (voice and Data) What steps would take?

Thanks everyone!

Purple

Re: Trouble routing vlans 3560

this is the layer 3 info did you create the layer 2 vlans ??? You need both the layer 2 side and the layer 3 side in order to work . Use the show vlan command and see if the layer 2 vlans are created. Just because you put the switchport access vlan 100 command on the interface does not mean the layer 2 vlan is created .

use

conf t

vlan 100

vlan 200

end

write mem

.

The vlans are created.

interface Vlan100

ip address 192.168.2.1 255.255.255.0

no ip route-cache

!

interface Vlan200

ip address 192.168.1.1 255.255.255.0

no ip route-cache

Re: Trouble routing vlans 3560

I think my problem is I cant ping a PC in the Access mode and a PC in the Voice mode on the other port. They both have to be set to Access. If I have had Cisco Phone plugged in, then CDP would take over and I could then ping the phone.

Hall of Fame Super Bronze

Re: Trouble routing vlans 3560

If you connect a PC on a port where you only configure the Voice Vlan, the Access Vlan will default to Vlan1.

If you aren't using Vlan1 for PC Access, you must manually configure all switchport for the desired Access Vlan in addition to the Voice Vlan.

209
Views
0
Helpful
13
Replies
CreatePlease to create content