Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Trouble with configuring DHCP with OSPF

Hello, I am writing to you because I am having trouble configurign DHCP with OSPF. My network is set up like so:

http://i.snag.gy/uVRhe.jpg

My show run output for router 1 is currently:

interface FastEthernet0/0
ip address 200.10.10.97 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 200.10.10.1 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.3 area 0
!

For the company router I have:

ip dhcp excluded-address 210.10.10.33 210.10.10.38
!
ip dhcp pool lan-a
network 200.10.10.32 255.255.255.224
default-router 200.10.10.33
dns-server 200.10.10.255
ip dhcp pool lan-b
network 200.10.10.64 255.255.255.224
default-router 200.10.10.65
dns-server 200.10.10.255
ip dhcp pool lan-c
network 200.10.10.96 255.255.255.224
default-router 200.10.10.2
dns-server 200.10.10.255
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 200.10.10.33 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 200.10.10.65 255.255.255.224
duplex auto
speed auto
!
interface Serial0/0/0
ip address 200.10.10.2 255.255.255.252
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0

Any help would be appriciated, as I have been trying to get this to work for the last few hours.

1 REPLY

Trouble with configuring DHCP with OSPF

Hi Nick,

I guess DHCP doesn't work for LAN-C / PC4?

PC4 sends DHCP Discover messages as Layer-2 broadcast, so the LAN-interface on Router 1 needs to act a a DHCP relay-agent, which is configured with the ip helper-address command.

Next step is connectivity between Router1 and the Company-Router. You have OSPF enabled for interfaces with a 10/8 IP-address but all the configured interface's IPs start with 200 or 210. Make sure that the Company-Router is able to reach Router1's LAN-interface by enabling OSPF for the 200 and 210 networks.

Finally you should exclude the LAN-interface of Router1 (.97) from the dynamic DHCP pool as well.

HTH

Rolf

642
Views
0
Helpful
1
Replies
CreatePlease to create content