Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Trouble with trunking and vlans

Okay I'm running a wsc2950c-24 switch and a 3640 router from cisco. And I follow the instructions they have on their site and I just can't get this thing to work prooperly.

The computer on Vlan 1 has an ip of 192.168.4.100. The computer on vlan 85 has an ip of 192.168.5.101. I can't get 5.101 to ping anything on the switch. But on 4.100 I can get it to ping both router addresses and the switch address.

My config files are below:

Switch:

Using 2263 out of 32768 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname swtmw-em-test1

!

enable secret 5 XXXX

enable password XXXXX

!

ip subnet-zero

!

vtp domain XXXXX

vtp mode transparent

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

vlan 81

name johdoe

shutdown

!

interface FastEthernet0/1

switchport access vlan 81

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 81

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 81

!

interface FastEthernet0/4

switchport access vlan 81

!

interface FastEthernet0/5

switchport access vlan 81

!

interface FastEthernet0/6

switchport access vlan 81

!

interface FastEthernet0/7

switchport access vlan 81

!

interface FastEthernet0/8

switchport access vlan 81

!

interface FastEthernet0/9

switchport access vlan 81

!

interface FastEthernet0/10

switchport access vlan 81

!

interface FastEthernet0/11

switchport access vlan 81

!

interface FastEthernet0/12

switchport access vlan 81

!

interface FastEthernet0/13

switchport access vlan 81

!

interface FastEthernet0/14

switchport access vlan 81

!

interface FastEthernet0/15

switchport access vlan 81

!

interface FastEthernet0/16

switchport access vlan 81

!

interface FastEthernet0/17

switchport access vlan 81

!

interface FastEthernet0/18

switchport access vlan 81

!

interface FastEthernet0/19

switchport access vlan 81

!

interface FastEthernet0/20

switchport access vlan 81

!

interface FastEthernet0/21

switchport access vlan 81

!

interface FastEthernet0/22

switchport access vlan 81

!

interface FastEthernet0/23

switchport trunk allowed vlan 1-90

switchport mode trunk

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface Vlan1

ip address 192.168.4.253 255.255.255.0

no ip route-cache

!

interface Vlan81

no ip address

no ip route-cache

!

ip default-gateway 192.168.4.254

ip http server

banner login ^C kdkakfjakjdflkjasdlkfjakjdsfla C

dddddddddddddddddddddddddddddddddddddddddddddddddddddddddd^C

!

line con 0

line vty 0 4

password XXXXX

login

line vty 5 15

password XXXXX

login

!

!

end

router:

Using 1358 out of 129016 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname rtrmw-em-test

!

enable secret 5 XXXXX

enable password XXXXX

!

ip subnet-zero

no ip routing

!

!

!

!

!

!

interface FastEthernet1/0

no ip address

no ip route-cache

speed auto

half-duplex

no mop enabled

!

interface FastEthernet1/0.1

encapsulation dot1Q 1 native

ip address 192.168.4.254 255.255.255.0

no ip route-cache

!

interface FastEthernet1/0.2

encapsulation dot1Q 81

ip address 192.168.5.254 255.255.255.0

no ip route-cache

!

ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password XXXXX

login

!

end

2 REPLIES
New Member

Re: Trouble with trunking and vlans

"no ip routing "

Check your router config.....you should have "IP ROUTING" enabled

Hall of Fame Super Bronze

Re: Trouble with trunking and vlans

Can 192.168.5.101 ping 192.168.5.254 ?

Have you configured 192.168.5.101 with default gateway of 192.168.5.254 ?

What switchports are both machine using on the switch ?

I also see ip routing is disabled in the router, it must be enabled.

__

Edison.

97
Views
0
Helpful
2
Replies
CreatePlease to create content