Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

troubleshooting internet connectivity

Hello, I've recently received some cisco routers and switches and I've been trying to teach myself how to configure them. Right now my setup is as follow.

ISP Router -> Cisco 2811 Router -> Cisco 2950 Switch -> Hosts

While connected through the console port on my cisco router I'm able to ping to my outside ip address as well as all my inside ip addresses. I'm also able to ping google.com.

This is where my problems start. When I'm sitting on my host pc I'm able to ping my outside ip address as well as my inside ip addresses but I have no internet connectivity so I can't ping google.com.

I have my cisco router setup to handout addresses through DHCP(192.168.1.0 network 255.255.255.0 subnet mask). My host PC is receiving an ip address of 192.168.1.100, subnet mask 255.255.255.0, default gateway 192.168.1.1, dns 192.168.1.1.

Im unsure how to go about fixing this issue. If I could get some advice I'd really appreciate it.

 

 

Show run(Cisco Router)

Building configuration...

Current configuration : 1389 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SeattleR1
!
boot-start-marker
boot-end-marker
!
no logging on
enable secret 5 $1$J/SN$EYHwGE3/xjyK5z7QVh9/g1
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
memory-size iomem 20
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool mypool
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 192.168.1.1
!
!
ip domain name SeattleR1.com
!
multilink bundle-name authenticated
!
!
!
!
!
!
license udi pid CISCO2811 sn FTX1103A4FV
username admin password 7 104D000A0618
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
 clock rate 125000
!
interface Serial0/0/1
 no ip address
 shutdown
 clock rate 125000
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 password 7 01100F175804
line aux 0
line vty 0 4
 password 7 110A1016141D
 transport input ssh
!
scheduler allocate 20000 1000
end

5 REPLIES
New Member

Here is my show running

Here is my show running-config for my cisco switch.

 

Building configuration...

Current configuration : 1564 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SeattleSW1
!
aaa new-model
enable secret 5 $1$69vB$L./pEEpM.IzIYfFhz45BW.
!
username admin password 7 13061E010803
ip subnet-zero
ip domain-name SeattleSW1.com
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!
interface FastEthernet0/2
 no ip address
!
interface FastEthernet0/3
 no ip address
!
interface FastEthernet0/4
 no ip address
!
interface FastEthernet0/5
 no ip address
!
interface FastEthernet0/6
 no ip address
!
interface FastEthernet0/7
 no ip address
!
interface FastEthernet0/8
 no ip address
!
interface FastEthernet0/9
 no ip address
!
interface FastEthernet0/10
 no ip address
!
interface FastEthernet0/11
 no ip address
!
interface FastEthernet0/12
 no ip address
!
interface FastEthernet0/13
 no ip address
!
interface FastEthernet0/14
 no ip address
!
interface FastEthernet0/15
 no ip address
!
interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 no ip address
!
interface FastEthernet0/18
 no ip address
!
interface FastEthernet0/19
 no ip address
!
interface FastEthernet0/20
 no ip address
!
interface FastEthernet0/21
 no ip address
!
interface FastEthernet0/22
 no ip address
!
interface FastEthernet0/23
 no ip address
!
interface FastEthernet0/24
 no ip address
!
interface Vlan1
 ip address 192.168.1.2 255.255.255.0
 no ip route-cache
!
ip http server
!
!
line con 0
 password 7 060506324F41
line vty 0 4
 password 7 121A0C041104
line vty 5 15
!
end

New Member

Can you provide the ip

Can you provide the ip addressing of your router WAN interfaces?

New Member

outside ip address 50.149.69

outside ip address 50.149.69.XXX

inside ip address 10.0.0.1 subnet 255.255.255.0

primary dns 75.75.75.75

secondary dns 75.75.76.76

Bronze

OK so there is no NAT

OK so there is no NAT configured on your router so if you can PING out to the internet I assume the ISP router is doing that for you?

Also you have a default route to 10.0.0.1, I assume FastEthernet0/1 is connected to your ISP router and it is getting a 10.0.0.X address via DHCP?

I think it's not working because your ISP router does not know about the 192.168.1.0/24 network. You would need to set a static 10.0.0.X address on your router then ask your ISP to add a static route to your 192. network via this 10. address.

Hope that helps!

Matty

New Member

If there's any other

If there's any other information I could provide that could help get my issue resolved I'll gladly provide it. I really want to figure how to fix it.

69
Views
0
Helpful
5
Replies