Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

trunk 3750 and 3850

I have a 3750 stack as my core switch in my Atlanta location. We recently purchased a new 3850, but I can't ping back and forward between them. They do see each other as CDP neighbors. Here is my setup

3750 -> core switch (10.11.1.2 - gateway)

garfield#sh ip int br | ex un
Interface              IP-Address      OK? Method Status                Protocol
Vlan10                 10.11.1.4       YES manual up                    up
Vlan41                 192.168.41.10   YES manual up                    up
Vlan112                10.11.2.7       YES manual up                    up
Vlan172                172.16.1.2      YES NVRAM  up                    up
Vlan192                192.168.40.4    YES manual up                    up
Vlan310                10.3.3.3        YES NVRAM  up                    up
garfield#

Ran these commands to create port chann:


int Gi1/0/49 & Gi2/0/49
shut
switchport
channel-group 10 mode active

exit
int port-channel 10 
switchport trunk enacap dot1q
switchport mode trunk
exit

int gi 1/0/49
no shut

int gi 2/0/49
no shut
end

Port-channel10 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0019.e78d.cc31 (bia 0019.e78d.cc31)
  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 0/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/0/49 Gi2/0/49
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:14:36, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     52181 packets input, 6623363 bytes, 0 no buffer
     Received 52039 broadcasts (51920 multicasts)

 

garfield#sh int port-chann 10 switch
Name: Po10
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

 

garfield#sh int port-chann 10 trunk

Port        Mode             Encapsulation  Status        Native vlan
Po10        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po10        1-4094

Port        Vlans allowed and active in management domain
Po10        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

Port        Vlans in spanning tree forwarding state and not pruned
Po10        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999
garfield#

 

Here is the config on the 3850 side: 

The 3850 has an IP address of 10.11.1.14 and IP routing is disabled (not sure if it needs to be).

Jon#sh ip int br | ex un
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  10.11.1.14      YES NVRAM  up                    up
Jon#

Jon#sh int port-chann 11 switchp
Name: Po11
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

 

 

Jon#sh int port-chann 11
Port-channel11 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 6cfa.8961.aeb1 (bia 6cfa.8961.aeb1)
  MTU 1500 bytes, BW 2000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/1/1 Gi2/1/1
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 9347000 bits/sec, 1532 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1162869640 packets input, 849966959309 bytes, 0 no buffer
     Received 444658674 broadcasts (421043246 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 421043246 multicast, 0 pause input

 


Jon#sh int port-chan 11 trunk

Port        Mode             Encapsulation  Status        Native vlan
Po11        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po11        1-4094

Port        Vlans allowed and active in management domain
Po11        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

Port        Vlans in spanning tree forwarding state and not pruned
Po11        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

 

What am I missing? I want to be able to use all my vlans on both switches. The fiber is connected, the ports are trunked, and the port-channel is up. At this point, I would have expected to be able to connect a laptop on the 10.11.1.x  subnet (10.11.1.120) to the new 3850, and ping a server on the same subnet (10.11.1.100) connected to the 3750. Instead, I get no reply. I can't ping the gateway (10.11.1.2 - 3750) either. The only ping reply I get, is if I ping the new switch (10.11.1.14), which is where the laptop is plugged in. I didn't think this setup would be complicated, but it's entirely possible that I missed some basic thing. I'm in no way a cisco expert, so I turn to you all for help. 

 

Any assistance is appreciated. 

 

Thanks. 

JD

 

 

 

 

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

JD,Based on my recent similar

JD,

Based on my recent similar issue i recommended to reboot.


Okay lets try this:
1- Default all the interfaces on both the boxes or remove the port-channel.
2- Reboot the 3850.
3- Configure the Port-channel first
4- Shut down the Physical interfaces on both the side.
5- Configure the physical interfaces by applying all the config.
6- Unshut the physical ports.

Let me know how this goes.

HTH

 

7 REPLIES
Hall of Fame Super Gold

Port-channel10 is up, line

Port-channel10 is up, line protocol is up (connected)
     reliability 255/255, txload 1/255, rxload 0/255

Wierd.  I've never seen an output like this before.  

 

Can you post the output to the command "sh etherchann <10 & 11> summary"?

New Member

Hi Leo, and thanks for your

Hi Leo, and thanks for your reply. 

I've made a change, so now each switch has the same port-chann number (10). Here is the new output, plus the config you requested: 

on the 3750 (core):

garfield#sh etherchann 10 summ
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SU)        LACP      Gi1/0/49(P) Gi2/0/49(P)

garfield#

garfield#sh int port-chan 10
Port-channel10 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0019.e78d.cc31 (bia 0019.e78d.cc31)
  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 0/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/0/49 Gi2/0/49
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:04:15, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     65862 packets input, 8361474 bytes, 0 no buffer
     Received 65720 broadcasts (65567 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 65567 multicast, 0 pause input
     0 input packets with dribble condition detected
     177085397 packets output, 156101710776 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
garfield#

 

On the 3850 (new):

Jon#sh etherchann 10 summ
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SU)        LACP      Gi1/1/1(P)  Gi2/1/1(P)

Jon#

Jon#sh int port-chann 10
Port-channel10 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is bc67.1c2c.8f31 (bia bc67.1c2c.8f31)
  MTU 1500 bytes, BW 2000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 255/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/1/1 Gi2/1/1
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2812328000 bits/sec, 478213 packets/sec
  5 minute output rate 1604000 bits/sec, 2809 packets/sec
     1211931813 packets input, 892022933648 bytes, 0 no buffer
     Received 476891456 broadcasts (452887224 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 452887224 multicast, 0 pause input
     0 input packets with dribble condition detected
     7131294 packets output, 511555866 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

 

Jon#sh int port-chann 10 trunk

Port        Mode             Encapsulation  Status        Native vlan
Po10        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po10        1-4094

Port        Vlans allowed and active in management domain
Po10        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999

Port        Vlans in spanning tree forwarding state and not pruned
Po10        1,10,41,70,72,110,112,172,192,222,310,400,410,722,999
Jon#

 

Jon#sh int port-chann 10 switchpor
Name: Po10
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

 

 

Hope this helps. I'm not sure where I went wrong on this set up. I also noticed that on the 3750, the 10.11.1.x ip address is on vlan 10, but on the new 3850, the 10.11.1.14 address is on vlan 1. Do I need to change that? Vlan 10 is used for my production systems, so I need to be careful with what changes I make there. 

 

Many thanks for your help. 

 

JD

Cisco Employee

JD,garfield#sh int port-chan

JD,


garfield#sh int port-chan 10
Port-channel10 is up, line protocol is up (connected)
     reliability 255/255, txload 1/255, rxload 0/255  >>>>>>>. Rxload 0- this is not good if you see this then the port-channel doesnt work.

Jon#sh int port-chann 10
Port-channel10 is up, line protocol is up (connected)
     reliability 255/255, txload 1/255, rxload 255/255 >>>. Rxload 255

Next Action:

=========

I appreciate if you could reboot both the boxes once.

HTH

Inayath

 

New Member

Thanks Inayath.  The 3750

Thanks Inayath. 

 

The 3750 (garfield) is my core production switch, so rebooting it is going to be a hard sell. Unless you mean reboot both 3850's boxes (the stack) only? Since the 3850 are new, they have nothing connected to them, and can be rebooted with no impact. 

 

How about doing a shut \ noshut on all the interfaces? You think that might help? Or how about tearing down, deleting and recreating the port-channels?

 

Thanks, 

 

JD

Cisco Employee

JD,Based on my recent similar

JD,

Based on my recent similar issue i recommended to reboot.


Okay lets try this:
1- Default all the interfaces on both the boxes or remove the port-channel.
2- Reboot the 3850.
3- Configure the Port-channel first
4- Shut down the Physical interfaces on both the side.
5- Configure the physical interfaces by applying all the config.
6- Unshut the physical ports.

Let me know how this goes.

HTH

 

New Member

Thank you. This is issue is

Thank you. This is issue is resolved. I ended up recreating the port channel, and created layer 3 SVI for the switches, for each VLAN.

For anybody else who may run into this, here is a sample of what I did. 

 

int Gi1/1/1

shut

switchport

switchport trunk allowed vlan ALL

switchport mode trunk

switchport nonegotiate

channel-group 2 mode active

 

int port-channel 2

switchport mode trunk

switchport trunk allowed vlan all

switchport nonegotiate

exit

 

Do the same on for all interfaces. Make sure your port channel numbers are the same and that your IP addresses are on the same vlan. I had my 10.11.1.x IP address on vlan 10 on switch, and the new switch IP of 10.11.1.xx was on vlan 1. 

 

It all works now. 

 

Thanks! 

Cisco Employee

wow as expected.can you

wow as expected.

can you please mark the thread as answered or solved rather than leaving it a unanswered.

379
Views
0
Helpful
7
Replies
CreatePlease login to create content