Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Trunk between 2620 & Nortel 5520 only shows 1 vlan connected on sh ip route

Hello All,

I am trying to setup routing correctly between a 2620 and Nortel 5520 Routing Switch.

I have vlans configured on the Nortel 5520 Switch with ip addresses.

Vlan 2 (Management) 10.130.2.28/24

Vlan 28 (Floor 28) 10.130.28.1/24

Vlan 128 (Floor 28 Voice) 10.130.128.1/24

Vlan 100 (VoIP Equipment) 10.130.100.1/24

On the 2620 I have 1 subinterface configured.

Fa0/0.2

ip address 10.130.2.1 255.255.255.0

The trunks are setup between the two, but whenever I do a 'sh ip route' I am only getting

10.130.2.0 is directly connected to Fa0/0.2

Thus, I cannot ping any of the other networks.

If I put in a static route

ip route 10.130.0.0 255.255.0.0 10.130.2.28

then i can ping the other networks, and routing is working.

I would like to set this up without the static route mentioned above because BGP will be the routing protocol used and I *think* i need all the 10.130.0.0 networks in the routers routing table.

I have tried setting

Fa0/0.2 to ip address 10.130.2.1 255.255.0.0

giving me a 'sh ip route' of

10.130.0.0 is directly connected to Fa0/0.2

but when I actually try to ping any of the other networks it fails. VICE-versa, the switch canot ping the router when it's setup this way. I have tried changing Vlan 2 ip address on the switch to 10.130.2.28/16, but it still wasn't working.

Thanks for any help!

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

Kenny

Wouldn't actually matter because of the fact that you have entered

ip route 10.130.0.0 255.255.0.0 10.130.2.28

then there would be a matching route for your "network 10.130.0.0 mask 255.255.0.0" entry.

The aggregate address is usually used when you don't have a specific match in the routing table ie. there just needs to be at least one subnet that falls within the aggregate address range. But you do have a specific match because of the 2600 needing to know where the other vlans live.

Jon

8 REPLIES
Hall of Fame Super Blue

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

Is there a reason why you are using a subinterface on the 2600 and are you running a routing protcol between the 2600 and the Nortel switch.

Basically you can do a couple of things

1) make the link between the 2600 and the Nortel switch a L2 trunk and add subinterfaces for all the vlans on the 2600. You then wouldn't need static routes

OR

2) start up a dynamic routing protocol between the 2600 and the Nortel - OSPF presumably.

It's not clear whether the existing link is a

1) L2 access link

2) L2 trunk

3) L3 routed link

Could you clarify ?

Jon

New Member

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

Hey Jon,

As we had previously talked about, the routing in my environment was completely messed up. So we were going to use BGP only within our environment so we didn't have to resort to having multiple routing protocols, thus, giving us the mess that we had before.

Basically the configuration we were going for was like so:

The router having an interface of 10.130.2.1 and the 5520 being the core router having all the vlans. Thus, not needing to create all the sub-interfaces.

Is this only happening because it is a cisco and nortel communication thing?

We have a 4507 core router in our environment with a 2851 and the 2851 can see all the connected vlans on the core 4507 router with a trunk link.

I have a subinterface for the router because its a personal preference of mine.

I'm not sure if i can give you the answer you want to the existing link.

Basically,

The 5520 is doing inter-vlan routing, while the 2620 will do inter-office routing. The 2620 should automatically make it a trunk port when i specified 'encap dot1q 2', and I made the 5520 a trunk port allowing all the vlans I have specified pass through

Hall of Fame Super Blue

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

Hi Kenny

How did that chat with the previous Network guy go ?

"Is this only happening because it is a cisco and nortel communication thing"

shouldn't be. It's the fact that this is a trunk link that's confusing but then again i guess that won't make that much difference as long as the relevant vlans are allowed on it.

Perhaps i'm not full understanding the setup but does the 2851 where it does work have a vlan database with the vlans in it ?

If you have the 2600 connected to the Nortel and you don't want to run a routing protocol between them then you really only have 2 choices

1) create subinterfaces for each vlan on 2600

OR

2) Use static routes

If you don't want to use 2 then the only way the 2600 will know about the other vlans is to create a subinterface for them.

Jon

New Member

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

Jon,

If I were to keep the static route

ip route 10.130.0.0 255.255.0.0 10.130.2.28

how would I setup BGP so that other routers running BGP would know to come there for the 10.130.0.0/16 network?

ie.

router bgp 100

network 10.130.0.0

or

router bgp 100

aggregate-address 10.130.0.0 255.255.0.0

thanks

Hall of Fame Super Blue

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

Kenny

Wouldn't actually matter because of the fact that you have entered

ip route 10.130.0.0 255.255.0.0 10.130.2.28

then there would be a matching route for your "network 10.130.0.0 mask 255.255.0.0" entry.

The aggregate address is usually used when you don't have a specific match in the routing table ie. there just needs to be at least one subnet that falls within the aggregate address range. But you do have a specific match because of the 2600 needing to know where the other vlans live.

Jon

New Member

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

thanks Jon!

as much as I hate static routes, I think it will be alot cleaner to just keep that one static route in there instead of running 2 routing protocols.

Thanks again for the help!

New Member

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

Do you have a dynamic routing protocol running on the 5520 and the 2620? I think you need to set up OSPF on the 5520 with each vlan as an interface.

New Member

Re: Trunk between 2620 & Nortel 5520 only shows 1 vlan connected

Hey Mark,

no I do not have OSPF or RIP running because I wanted to stay away from having multiple routing protocols in our environment. We basically just wanted to use BGP.

I figured that the router and the core switch could see each other because all those vlans and interfaces are 'directly connected'.

and yes, all vlans have ip addresses for interfaces assigned to them

1134
Views
0
Helpful
8
Replies
CreatePlease to create content