Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Trunk between Catalyst 4000 & 6509

Hi,

We are in the process of migrating some distribution switches from our Foundry core switch to a new Cisco 6509.

We first disable the port on the 4000 that connects to the Foundry (let 3-4 pings drop just to make sure the old port is disabled) and then enable the port on the 6509 that is suppose to be the new trunk port. At this point, we notice:

1: The new trunk port link light on the 4000 never turns on.

2: The new port on the 6509 show up/up.

3:The log on the 4000 shows that there is vlan flapping between the old port (disabled on going to the foundry) and the new port (going to the 6509).

Config on the 4000:

interface GigabitEthernet1/45
description Fiber to CoreSw02
switchport trunk encapsulation dot1q
switchport mode trunk
speed nonegotiate
spanning-tree portfast
spanning-tree bpdufilter enable
spanning-tree bpduguard enable

Config on the 6509:

interface GigabitEthernet1/2/24
description Fiber to PhlDistSW13 G1/45
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
speed nonegotiate
spanning-tree portfast disable
spanning-tree bpduguard disable

1 REPLY
Hall of Fame Super Blue

Re: Trunk between Catalyst 4000 & 6509

sudip.acharya1 wrote:

Hi,

We are in the process of migrating some distribution switches from our Foundry core switch to a new Cisco 6509.

We first disable the port on the 4000 that connects to the Foundry (let 3-4 pings drop just to make sure the old port is disabled) and then enable the port on the 6509 that is suppose to be the new trunk port. At this point, we notice:

1: The new trunk port link light on the 4000 never turns on.

2: The new port on the 6509 show up/up.

3:The log on the 4000 shows that there is vlan flapping between the old port (disabled on going to the foundry) and the new port (going to the 6509).

Config on the 4000:

interface GigabitEthernet1/45
description Fiber to CoreSw02
switchport trunk encapsulation dot1q
switchport mode trunk
speed nonegotiate
spanning-tree portfast
spanning-tree bpdufilter enable
spanning-tree bpduguard enable

Config on the 6509:

interface GigabitEthernet1/2/24
description Fiber to PhlDistSW13 G1/45
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
speed nonegotiate
spanning-tree portfast disable
spanning-tree bpduguard disable

Firstly can you remove the "spanning-tree portfast" on the gi1/45 interface on the 4000 as you should never have portfast on a trunk link. That may well solve your problem. If not try clearing the arp cache on the 4000 as well.

Also can you remove spanning-tree bpdufilter and bpduguard because this is exactly what you don't want on your ports as switch links will indeed send BPDUs between each other.

Jon

314
Views
0
Helpful
1
Replies
CreatePlease to create content