Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trunk Configurations on Catalyst 2970G

I've noticed when using Smartports srr-queue ...share and srr-queue....shape are configured on Trunk ports. Do those settings add latency to the port where there is only Data and not VOIP? My VOIP is on VLAN 20 which has access to the Data VLAN (10) by virtue of using the additional port @ the IP Phone for desktop connection.

interface GigabitEthernet0/1
description connection to voicerouter
switchport access vlan 30
switchport trunk encapsulation dot1q
switchport mode trunk
switchport protected
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust dscp

interface GigabitEthernet0/3
description connection to Data Switch

switchport access vlan 10
switchport mode access
switchport voice vlan 20
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust cos

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Trunk Configurations on Catalyst 2970G

Hello!

srr-queue bandwidth shape command assign shaped weights to enable  bandwidth shaping on the four egress queues mapped to a port. Each queue has guaranteed a percentage of the  bandwidth, and one queue is rate-limited to that amount. You can use this command to calm burst traffic but be aware that shaped traffic does not use more than the  allocated bandwidth even if the link is idle. If you have there a wrong value you can end up with packet drops and latency, and you don't want this especially for voice traffic.

srr-queue bandwidth share command assign the shared weights to enable  bandwidth sharing on the four egress queues mapped to a port. In shared mode, the queues share the bandwidth  among them according to the configured weights. The bandwidth is  guaranteed at this level but not limited to it. For example, if a queue  empties and does not require a share of the link, the remaining queues  can expand into the unused bandwidth and share it among themselves.

In more human terms, both commands are used to limit the bandwidth, with the difference that shaped method is fixed bandwidth / queue and cannot borrow from other queues even if they are empty and share method is fixed bandwidth / queue but they can borrow bandwidth from other queue if it's necessary and that queue has enough bandwidth to share.

Yes, this commands can add delay to one queue in order to prioritize another one. Imagine this like VoIP get prioritize in from of HTTP traffic.

Cheers,

Calin

2 REPLIES

Re: Trunk Configurations on Catalyst 2970G

Hello!

srr-queue bandwidth shape command assign shaped weights to enable  bandwidth shaping on the four egress queues mapped to a port. Each queue has guaranteed a percentage of the  bandwidth, and one queue is rate-limited to that amount. You can use this command to calm burst traffic but be aware that shaped traffic does not use more than the  allocated bandwidth even if the link is idle. If you have there a wrong value you can end up with packet drops and latency, and you don't want this especially for voice traffic.

srr-queue bandwidth share command assign the shared weights to enable  bandwidth sharing on the four egress queues mapped to a port. In shared mode, the queues share the bandwidth  among them according to the configured weights. The bandwidth is  guaranteed at this level but not limited to it. For example, if a queue  empties and does not require a share of the link, the remaining queues  can expand into the unused bandwidth and share it among themselves.

In more human terms, both commands are used to limit the bandwidth, with the difference that shaped method is fixed bandwidth / queue and cannot borrow from other queues even if they are empty and share method is fixed bandwidth / queue but they can borrow bandwidth from other queue if it's necessary and that queue has enough bandwidth to share.

Yes, this commands can add delay to one queue in order to prioritize another one. Imagine this like VoIP get prioritize in from of HTTP traffic.

Cheers,

Calin

New Member

Re: Trunk Configurations on Catalyst 2970G

Thanks Calin. Very on point.

If these settings are set at the port then following best practice methods, the same settings, in essence, would be "double-queueing", correct?

Switch 1 - 3750G-POE 48PS

VLAN 10 - Data

VLAN 20 - Voice

     Interface settings

     switchport access vlan 10
     switchport mode access
      switchport voice vlan 20
      switchport port-security
      switchport port-security aging time 2
      switchport port-security violation restrict
      switchport port-security aging type inactivity
      srr-queue bandwidth share 10 10 60 20
      srr-queue bandwidth shape 10 0 0 0
      queue-set 2
      mls qos trust device cisco-phone
      mls qos trust cos
      auto qos voip cisco-phone
      macro description cisco-phone
      spanning-tree portfast
      spanning-tree bpduguard enable

Port 48 Trunk to Switch 2

description 2nd Series 3750G
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mls qos trust cos
auto qos voip trust
macro description cisco-wireless
spanning-tree portfast
spanning-tree bpduguard enable

------------------------------------------------

Switch 2 - 3750G-48PS

VLAN 10 - Data

Interface settings

switchport access vlan 10
     switchport mode access
      switchport voice vlan 20
      switchport port-security
      switchport port-security aging time 2
      switchport port-security violation restrict
      switchport port-security aging type inactivity
      srr-queue bandwidth share 10 10 60 20
      srr-queue bandwidth shape 10 0 0 0
      queue-set 2
      mls qos trust device cisco-phone
      mls qos trust cos
      auto qos voip cisco-phone
      macro description cisco-phone
      spanning-tree portfast
      spanning-tree bpduguard enable

Port 48 Trunk to Switch 1

switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 1,10,20,30,99,1002-1005
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust dscp

982
Views
0
Helpful
2
Replies
CreatePlease login to create content