Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

trunk connection

I have a server that shared the ethernet port for the NIC and the IPMI. I want to associate a vlan (10) to IPMI and use the native vlan 1 for the NIC. I use a 2960G switch, the ports are configured in mode trunk and nonegotiate.

The IPMI configured in the vlan 10 not respond (arp, ping). Moreover, if I replace the cisco switch with a non manageable switch everything works OK. What is wrong in this trunking configuration?

Regards,

Liana

----------------------------------------------

eswu0c0#sh interfaces gigabitEthernet 0/10 status

Port Name Status Vlan Duplex Speed Type

Gi0/10 connected trunk a-full a-1000 10/100/1000BaseTX

eswu0c0#sh interfaces gigabitEthernet 0/12 status

Port Name Status Vlan Duplex Speed Type

Gi0/12 connected trunk a-full a-1000 10/100/1000BaseTX

eswu0c0#sh interfaces gigabitEthernet 0/10 trunk

Port Mode Encapsulation Status Native vlan

Gi0/10 on 802.1q trunking 1

Port Vlans allowed on trunk

Gi0/10 1-4094

Port Vlans allowed and active in management domain

Gi0/10 1,5,10

Port Vlans in spanning tree forwarding state and not pruned

Gi0/10 1,5,10

eswu0c0#sh interfaces gigabitEthernet 0/12 trunk

Port Mode Encapsulation Status Native vlan

Gi0/12 on 802.1q trunking 1

Port Vlans allowed on trunk

Gi0/12 1-4094

Port Vlans allowed and active in management domain

Gi0/12 1,5,10

Port Vlans in spanning tree forwarding state and not pruned

Gi0/12 1,5,10

eswu0c0#sh running-config

Building configuration...

Current configuration : 3012 bytes

!

! Last configuration change at 13:31:41 UTC Fri Jul 3 2009

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname eswu0c0

!

no aaa new-model

vtp mode transparent

ip subnet-zero

!

!

!

no file verify auto

!

spanning-tree mode pvst

spanning-tree portfast default

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 5

....

!

vlan 10

........

!

........

interface GigabitEthernet0/10

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet0/12

switchport mode trunk

switchport nonegotiate

!

...............

4 REPLIES
New Member

Re: trunk connection

Hi

You haven't defined the encapsulation on interface GigabitEthernet0/10 , unless the switch automatically is set to a trunking encapsulation e.g dot1q.

Dan

New Member

Re: trunk connection

Hi Dan,

In 2960 series only dot1q is supported so the "switchport trunk encapsulation dot1q" command is not supported.

Hall of Fame Super Gold

Re: trunk connection

Why is the switchport configured as a Trunk instead of a switchport access vlan 10?

New Member

Re: trunk connection

I want to use the native vlan 1 for the ethernet interface of the server (the IPMI and NIC are connected on the same switch port). Moreover, the IPMI is already configured in vlan 10.

258
Views
0
Helpful
4
Replies
CreatePlease to create content