Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Trunk help

Hi, based on:

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a00800949fd.shtml

A little progress, the trunk is nearly working I think, but both PC's can't ping each other.

I have a PC (PC A) with:

IP address - 192.168.2.50

Gateway - 192.168.2.1

In FE 0/9 of switch VLAN10

I have a PC (PC B) with:

IP address - 192.168.3.10

Gateway - 192.168.3.1

In FE 0/17 of switch VLAN20

PC A can ping 192.168.2.1 and 192.168.3.1

PC B can ping 192.168.3.1 but NOT 192.168.2.1

What could this be?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Trunk help

Hello Andy,

I was meaning

sh int fas0/1 switchport

Excuse me for not having typed an enter before.

I got it :

no ip routing

in the router config

you need to turn ip routing on the c2600

conf t

ip routing

Hope to help

Giuseppe

20 REPLIES
Hall of Fame Super Silver

Re: Trunk help

Hello Andy,

I've never seen this to work:

interface FastEthernet0/0.10

encapsulation dot1Q 10

>>> ip address 192.168.2.1 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.3.1 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface FastEthernet0/0.100

encapsulation dot1Q 100

>>> ip address 192.168.2.98 255.255.255.0

no ip route-cache

!

how can two subinterfaces have overlapping IP addresses ?

have you tried this config ?

you should get an error for the second one you try to add

192.168.2.1 and 192.168.2.98 are in the same subnet

I would suggest you to use a one to one corrispondence between vlans and IP subnets.

about PC B:

verify it has the correct gateway (192.168.3.1)

Hope to help

Giuseppe

New Member

Re: Trunk help

Hi,

I did let me add these 2 sub interfaces. Anyway I have removed interface FastEthernet0/0.100 and checked the gateway is correct too as I can ping 192.168.3.1 from PC B, still the same problem. PC B cannot ping 192.168.2.1 or PC A but can ping the subinterface of 192.168.3.1.

Does the switch need a default gateway?

Purple

Re: Trunk help

The default gateway on a layer 2 switch is just to be able to manage the switch from a different subnet than the mgt. vlan is on , has nothing to do with any devices attached to it . Do you have the same native vlan on both the router which appears to be vlan 1 and the 2950 ? On the router try

interface FastEthernet0/0.10

encapsulation dot1Q 10 native

on the switch connection

try

switchport trunk native vlan 10 .

New Member

Re: Trunk help

I'm a little confused here. I haven't done anything with the native vlan 1 as I didn't think I was using it, why do I?

Also you only mention adding it to vlan 10 and not 20.

Blue

Re: Trunk help

Have you thought that there may be a personal firewall on PC A, preventing PC B from pinging it?

Ive seen that many times before.

OR

PC A has a route table configured on it and does not have a route for hosts outside its local subnet, or no route back to PC B's subnet.

Seen that a zillion times, too.

Thanks

Victor

New Member

Re: Trunk help

Hi, the 2 laptops seem fine, if I put them in the same vlan using the same IP range then they can ping each other. I did a route print on their command prompt as well and there are no addition persistant routes.

Someone has mentioned I need to add the native vlan to the trunks, what is this native vlan used for?

Hall of Fame Super Silver

Re: Trunk help

Hello Andy,

in an 802.1Q trunk the native vlan is the only vlan that have its frames sent untagged = without an header 802.1Q.

It is thought to provide backward compatibility to NICs that are not able to use and understand 802.1Q tagged frames.

A mismatch in native vlan can cause IP connectivity issues:

if one trunk side thinks that native vlan is x and the other side thinks is vlan y untagged frames from vlan x are sent and the other side treats them as frames in vlan y and tries to forward them in its vlan y's ports.

In your case I would point to the GW config of the second laptop if it is wrong or missing it could be unable to reach ip hosts in different subnets.

Also Victor's suggestion is good : many and many times users complain of ip connectivity and they have a sw firewall running on the PC.

Here native vlan should be the default one that is 1 but it is not permitted on the trunk on the switch side.

Hope to help

Giuseppe

New Member

Re: Trunk help

Hi,

I replaced the laptop with a router with an IP of 192.168.3.10/24 and ip default-gateway of 192.168.3.1 and I get the same problem.

Do my configs look good and do I need to add the native vlan 1 to the router? If so do I add it to all subinterfaces?

Thanks

Purple

Re: Trunk help

If you don't add the native vlan to the router it is a default of 1 just make sure the connecting link on the 2950 side is also 1 , if you haven't changed it then it should be 1 by default also , just look at the config on the switchport if it doesn't have a "switchport trunk native vlan X" command then it is 1 by default.

New Member

Re: Trunk help

Thanks, do you not see any configs attached, looks like I missed them off.

New Member

Re: Trunk help

Here are the configs.

New Member

Re: Trunk help

Here are the configs.

Hall of Fame Super Silver

Re: Trunk help

Hello Andy,

in order to get better help other info is needed :

on what port is connected the router

I suppose f0/1

on what ports are the PCs/routers

ip addr 192.168.3.x must be in vlan 20

post a sh int fas0/1 switchport so we can check if it is trunking, what protocol is using and what vlans are permitted

Hope to help

Giuseppe

New Member

Re: Trunk help

Hi,

As my first post states:

I have a PC (PC A) with:

IP address - 192.168.2.50

Gateway - 192.168.2.1

In FE 0/9 of switch VLAN10

I have a PC (PC B) with:

IP address - 192.168.3.10

Gateway - 192.168.3.1

In FE 0/17 of switch VLAN20

And you are correct the router is in FE0/1

Output:

Switch#sh int fas0/1

FastEthernet0/1 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 000f.2477.0401 (bia 000f.2477.0401)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:30, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 1000 bits/sec, 2 packets/sec

87 packets input, 11418 bytes, 0 no buffer

Received 30 broadcasts (21 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 21 multicast, 0 pause input

0 input packets with dribble condition detected

1658 packets output, 120475 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Switch#

Hall of Fame Super Silver

Re: Trunk help

Hello Andy,

I was meaning

sh int fas0/1 switchport

Excuse me for not having typed an enter before.

I got it :

no ip routing

in the router config

you need to turn ip routing on the c2600

conf t

ip routing

Hope to help

Giuseppe

New Member

Re: Trunk help

Well done.

I'm sorry I missed that too.

For my understanding Guiseppe, does the native vlan play any role in this setup? I'm confused why it is required?

Also I want to draw this netork diagram for my documentation, do you know of a tool that can do this that's free?

Here is the info anyway that you wanted :)

Switch#sh int fas0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

New Member

Re: Trunk help

Hi,

How would I now set this up so I can telnet to the switch from the users VLAN 10?

Thanks

Hall of Fame Super Silver

Re: Trunk help

Hello Andy,

on the switch you just need to create an SVI for vlan 10

int vlan 10

ip address ....

no shut

the address must be in ip subnet associated to vlan 10.

Hope to help

Giuseppe

New Member

Re: Trunk help

Hi,

SVI, is this a sub vlan interface? So o I create this on the switch:

int vlan 10

ip address ....

no shut

Then on the router aswell or just the switch and does the switch need a gateway?

Hall of Fame Super Silver

Re: Trunk help

Hello Andy,

only on the switch and then you are right you need to specify the router ip address in vlan 10 as the default-gateway for the switch

int vlan 10

ip address 192.168.2.x

no sh

where x stays for the last byte and is what you want among the free addresses.

ip default-gateway 192.168.2.1

Sorry for the missing info

Hope to help

Giuseppe

152
Views
0
Helpful
20
Replies
CreatePlease to create content