Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Trunk issue between 3750 and 2950

Trying to connect a Cisco 3750 to a 2950 using fibres. Connected the two machines, I was expecting to see some activity LEDs are showing green, but ports are showing down, down.

switch 2950 would not accept the following command as well "switchport trunk encapsulation dot1q"

Cisco3750:

interface GigabitEthernet1/0/26

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

Cisco2950:

interface Gigabitethernet0/1

switchport mode trunk

switchport nonegotiate

4 REPLIES
New Member

Re: Trunk issue between 3750 and 2950

Catalyst 2950 switches only support 802.1Q trunking and do not support ISL trunking.

Could you share any error log message?

New Member

Re: Trunk issue between 3750 and 2950

We can't see anyting in error logs. Both the port are no shut. But the link doesn't come up. We thought it was the cable but if we use that cable to another switch the portcomes up fine. So the cable is fine.

It looks like something wrong in configuration can you highlight on the configuration we have.

Cisco3750:

interface GigabitEthernet1/0/26

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

Cisco2950:

interface Gigabitethernet0/1

switchport mode trunk

switchport nonegotiate

New Member

Re: Trunk issue between 3750 and 2950

Only a guess but you have probably put a gigabit module in your 3750 and the 2950 is only running 100mb

each fibre module has a sticker on saying what speed it will run (this is hard coded into te module and cannot be changed by command line)

you meay need to get a 100mb fibre module for your 3750

worth checking!

bh
New Member

Re: Trunk issue between 3750 and 2950

Hi Nishit,

I think you should check with the SFP and GIBIC that are used to connect both the switches as Single Mode and Multimode Fiber modules are available so you can check the modules or give the detail of used modules

Regards,

Bhargav

882
Views
0
Helpful
4
Replies
CreatePlease to create content