Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trunk Ports

I have the following configuration.

router (2821 with nm esw016) - trunk (single cable) - switch (3550)

I configured the router to be vtp master and switch to be client.

I need to be able to telnet into both the switch and the router from a client plugged into the switch.

I have done on router:

vlan database

vlan 2 name Enabled-Interfaces

vlan 3 name Disabled-Interfaces

vtp mode server

vtp domain test

vtp v2-mode

interface gi0/0

desc connection to outside link

ip address 10.0.1.1 255.255.255.252

ip nat outside

interface gi1/15

desc trunk to switch

switchport mode trunk

interface Vlan 2

desc inside clients

int Vlan2

ip address 192.168.3.1 255.255.255.0

ip nat inside

on siwtch

ip default gateway 192.168.3.1

vtp mode client

vtp domain test

int gi0/1

Description Trunk to Router

switchport trunk encapsulation dot1q

switchport mode trunk

no shut

int range gi0/3 - 48

Desciption Disabled Ports

switchport mode access

switchport access vlan 3

shut

int gi0/3

Desc client

switchport access vlan 2

switchport mode access

no shut

I was thinking it would be best to create loopback interface on both the router and switch something like 1.1.1.1/32 for router and 1.1.1.2/32 on switch and create a route on the router to get back to 1.1.1.2/24 got o vlan 2. But no luck.

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Trunk Ports

Chris

No problem, we've all had those moments :-)

Glad you go it working.

Jon

8 REPLIES
Hall of Fame Super Blue

Re: Trunk Ports

Have you missed out the vlan interface from your posted config on the 3550 switch ?

If not you need to create a vlan 2 interface on the 3550 ie.

int vlan 2

ip address 192.168.3.x where x is an unused IP from that subnet.

You have already set the default-gateway on the switch so you should be good to go.

Jon

New Member

Re: Trunk Ports

I can now login to the switch from the client; however when I try to connect to the router at 192.168.3.1 (router) I get connection refused.

If I try from the switch to the router no problem.

If I try from the router to switch I get connection refused.

If I try and put a loopback on the router and telnet to it I get connection refused.

Ideas

Hall of Fame Super Blue

Re: Trunk Ports

The client is in vlan 2 ?

Can you post the full config of the switch and router.

Jon

New Member

Re: Trunk Ports

Yes the client is in vlan 2. I have attached the configurations.

Hall of Fame Super Blue

Re: Trunk Ports

Can you just clarify - your switch is only allowing ssh so are you using ssh to connect to switch from client or telnet ?

Jon

New Member

Re: Trunk Ports

Boy do I feel dumb right about now. I guess in my configuration I forgot to configure ssh on the router, so of course ssh would not work when I tried to connect.

Everything is working just fine, just not enough mountain dews or maybe too many.

Thanks

Hall of Fame Super Blue

Re: Trunk Ports

Chris

No problem, we've all had those moments :-)

Glad you go it working.

Jon

New Member

Re: Trunk Ports

Well you need a l3 interface to reach your default gateway on the switch. You should create a vlan 2 interface on the switch, on the 192.168.3.0 network. If you need to reach your loopbacks you also need to enable routing on your switch so that it routes between the interfaces. Then remove your default-gateway command and add a 0/0 ip route instead.

142
Views
0
Helpful
8
Replies
CreatePlease to create content