Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Trunking and telnet problem

Hi Everybody,

I have pasted the whole configuration of my cisco 3760 switch.

I have two issues.

1. I cannot telnet to this switch.

2. on ethernet port 1/0/1 i have configured switch mode trunk. i am not getting ip address on this port other wise i am getting ip where ever access mode is configure. i need to configure port 1 trunked.

Am i missing any command or config. Any help would be helpful

version 12.2

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname ABCD2013SW01

!

logging buffered 64000 debugging

no logging console

enable secret 5 ----------------------

enable password 7 -------------------

!

username badmin privilege 15 secret 5 $1$3xoh$Hpp2jaldsfjladsfj

username muadminas privilege 15 secret 5 $1$YJb6$sCdareljlkje9ff

aaa new-model

aaa authentication login CON local

aaa authentication login VTY local

aaa authentication enable default enable

aaa authorization exec default local

!

aaa session-id common

clock timezone CET -5

clock summer-time EDT recurring

switch 1 provision ws-c3750g-24ts-1u

vtp mode transparent

ip subnet-zero

no ip source-route

ip routing

ip icmp rate-limit unreachable 1000

ip domain-name xxxxxx.xxx

ip name-server 192.168.1.2

ip name-server 192.168.1.3

!

ip dhcp-server 192.168.1.3

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

--More--         !

vlan internal allocation policy ascending

!

vlan 2

name inside

!

vlan 8

name Internal_LAN

!

interface Null0

no ip unreachables

!

interface GigabitEthernet1/0/1

description **LAN**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-10

switchport mode trunk

no logging event link-status

spanning-tree portfast

!

interface GigabitEthernet1/0/2

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/3

description *** User Port ***

switchport access vlan 8

switchport mode access

no logging event link-status

spanning-tree portfast

!

interface GigabitEthernet1/0/4

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/5

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/6

description *** User Port ***

switchport access vlan 2

switchport mode access

--More--         !

interface GigabitEthernet1/0/7

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/8

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/9

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/10

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/11

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/12

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/13

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/14

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/15

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/16

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/17

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/18

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/19

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/20

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/21

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/22

description *** User Port ***

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/23

description *** User Port ***

switchport access vlan 8

switchport mode access

!

interface GigabitEthernet1/0/24

description *** User Port ***

switchport access vlan 8

switchport mode access

!

interface GigabitEthernet1/0/25

  description **UPLINK**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-10

switchport mode trunk

!

interface GigabitEthernet1/0/26

description **UPLINK**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-10

switchport mode trunk

!

interface GigabitEthernet1/0/27

description **UPLINK**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-10

switchport mode trunk

!

interface GigabitEthernet1/0/28

description **UPLINK**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-10

switchport mode trunk

!

interface Vlan1

no ip address

no ip redirects

ip directed-broadcast

no ip proxy-arp

shutdown

!

interface Vlan2

description ** Management **

ip address 192.168.1.92 255.255.255.0

no ip redirects

ip directed-broadcast

no ip proxy-arp

!

interface Vlan8

description ** Internal_LAN **

ip address 172.168.1.92 255.255.255.0

ip helper-address 192.168.1.3

no ip redirects

ip directed-broadcast

no ip proxy-arp

!

ip default-gateway 192.168.1.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip http server

ip http authentication local

!

access-list 97 remark ** NTP-ACCESS **

access-list 97 remark ** NTP-Server

access-list 97 permit 192.168.1.3

access-list 97 deny   any log

access-list 98 remark ** SNMP-ny   any log

access-list 98 remark ** SNMP-ACCESS  **

access-list 98 permit 192.168.1.60

access-list 98 deny   any log

access-list 99 remark ** VTY_ACCESS **

access-list 99 deny   any log

access-list 99 permit 192.168.1.0 0.0.0.255

snmp-server community abiYHORHAEN RO

snmp-server chassis-id ABCD2013SW01

radius-server source-ports 1645-1646

!

control-plane

!

banner exec ^CCCCCCCCC

    VMWAFAR TECHNOLOGY

you are now connected to: $(hostname).$(domain)

^C

banner login ^CCCCCCCCC

********************************************************************

**      banner                                                    **

**********************WARNING***************************************

*secure                                                            *

********************************************************************

^C

!

line con 0

exec-timeout 30 0

login authentication CON

history size 30

transport output none

stopbits 1

line vty 0 4

access-class 99 in

exec-timeout 30 0

password 7 091D5EADKRCR130700

logging synchronous

login authentication VTY

length 0

history size 30

transport preferred none

transport output none

line vty 5 15

access-class 99 in

exec-timeout 30 0

password 7 091D5E080138934450

logging synchronous

login authentication VTY

length 0

history size 30

transport preferred none

transport output none

!

ntp clock-period 36028917

ntp access-group peer 97

ntp server 192.168.1.7 prefer

end

Everyone's tags (2)
2 REPLIES
New Member

Trunking and telnet problem

1

you need to rewrite access-list 99

or delete it and rewrite it back

it should be

access-list 99 permit 192.168.1.0 0.0.0.255

access-list 99 deny   any log

2

try to add

switchport trunk native vlan vlan_ID

where vlan_ID is either 2 or 8


New Member

Trunking and telnet problem

Thanks, with the help of your suggestion the problem no 1 is solved and I can telnet now. The second problem is partially solved, now i can get Dynamic ip from vlan 2 with the suggested configuration. I can get through with VLAN 8 either way dynamic or static.

229
Views
3
Helpful
2
Replies