Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trunking between Huawei S3900 and Cisco catalyst 3750

One of my edge Huawei S3700  switches  is dead, I am going to replace it with a Cisco switch Catalyst 3750 series PoE-48 via a trunk link  with GE fiber port on both ends, please see the diagram below.
                                  trunk                     trunk
   Core switchrouter<----------S3700<--------------->Cisco Catlyst 3750

I haven’t touch Cisco switch for many years, I would like to ask the following questions:

1.)      Do I need to take any precaution before connecting this Cisco switch into my Huawei network? Only one link between S3700 and C3750, so I don't need worry anout STP? Do I need to worry about Default vlan regarding trunking port?
2.)      I need to use different trucking protocol e.g. 802.1Q etc to interconnect these two switches (S3700-28TP-SI-AC and Catalyst 3750), please see the following configuration:
 
For C3750:
 
switchport trunk encapsulation dot1q
switchport trunk native vlan (What you want)
switchport trunk allowed vlan (VLANs required)
switchport mode trunk
spanning-tree portfast trunk

For S3700:

 port link-type trunk
 port trunk permit vlan all

Do you think the configurations above are right?

Do I need to manually enter Duplex and speed options ?       


3.)If the configurations are not right, then what are the commands for trucking port/link should I use on the Cisco switch (it uses IOS software) and Huawei switch?  Procedures of the commands would be really helpful !

Any information and help would be much appreciated.

Thanks

Regards

2 REPLIES
New Member

There are no complications,

There are no complications, however, if you were connecting to another Cisco device, then thats another story!

 

I woulden't personally use one uplink though, STP is on by default (I would hope it is on your other devices as well?)

 

Speed etc will auto negotiate, as a matter of interest if ever you change this you need to ensure you use a crossover cable to interconnect the two switches!

 

Your config is correct, however, by looking at your second config, you want all the VLANS to traverse the trunk, if so then you do not need to individually specify them, since all VLANS are allowed by default.

 

The native VLAN has to match what it is on the rest of your network.

 

The only other thing I would say is the 3750 isn't an access layer switch, so if you have any plans for the future it's worth using this at the distribution or core layer and getting something like a 2960.

Martin

 

 

 

 

Hello

Hello


 3750 - basic config


 ================


See as you are using this switch as an host switch you need to make sure ip routing isn't enabled ( it isn't by default)


Also it looks like the s3700 Huawei switch is permitting all vlans and I assuming the default native vlan is 1 ( as is cisco) so no need to specify the native either.

If you are requiring the access ports on this new cisco 3750 to be in multiple vlans then usually cisco to cisco interconnect would ultise VTP for vlan propagation however this wont occur between the Huawei switch, so you will need to manually add the vlans on the switch also.


so to summarize below is a basic host switch config for 3750.


conf t

no ip routing

hostname XXXXXX
username xxxx privilege 15 secret xxxxxxx
service password-encryption
enable secret xxxxx

security passwords min-length xx
security authentication failure rate xx log
aaa new-model aaa authentication login default local

logging buffered 4096


no service udp-small-servers
no service tcp-small-servers


service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no ip domain-lookup


spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default


int vlan x ( this may or not be vlan 1 - its whatever the L3 vlan interface is on the core switch for management connectivity)
ip address x.x.x.x y.y.y.y.
exit

ip default-gateway x.x.x.x ( ip address of CORE SVI management interface)

 

vlan x,x,x,x ( add the L2 vlans to the switch as vtp would not be used between the Huawei switch)
exit


int gigx/x
Description Link to Huawei switch
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no shut
( no need for spanning-tree portfast trunk- this is usually only for ESX host ports)

 

int rang fa0/1 -48
Description - Access-ports
switchport host
switchport access vlan x (wihout this defaults to vlan 1)
no shut


clock timezone gmt 0

ntp peer
ntp server x.x.x. prefer


res
Paul

Please don't forget to rate any posts that have been helpful. Thanks.
1580
Views
0
Helpful
2
Replies
CreatePlease to create content