Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Trunking help

Hello everyone,

I have a problem getting a trunk port working between a 3750 stack and a 4507 chassis. The 4507 will form my new core but I am trying to configure it along side before testing and rollout but can't get it talking on my management VLAN. I have a VLAN setup as my management network on the 3750 but cannot get it to ping the new 4507, an excerpt from my config is below

interface Vlan21

description Native

ip address 10.50.0.129 255.255.255.128

end

I have also setup the 4507 with VLAN 21

interface Vlan21

ip address 10.50.0.131 255.255.255.128

no ip route-cache

end

VTP has been set to server on the 3750 and client on the 4507 but I still cannot ping the interfaces from each device

Port Config on the 3750

interface GigabitEthernet2/0/24

description Server Core LINK

switchport trunk encapsulation dot1q

switchport trunk native vlan 21

switchport mode trunk

end

Port Config on the 4507

interface GigabitEthernet1/48

switchport trunk native vlan 21

switchport mode trunk

end

Any help would be apprecaited

Thanks

Matt

Everyone's tags (2)
25 REPLIES
Purple

Re: Trunking help

Is the L2 vlan created on both sides ??  Show vlan to verify vlan 21 is operating on both sides, trunk setup looks ok .  Is this a client/server setup or transparent ? If client/server check the vtp domain name. L1 connectivity show as active or connected ?

New Member

Re:Trunking help

You can also check cdp for information, and ip route table. Does the rest of vlans pass from the link?
In vtp check domain, version, authentication.
Also issue the switchport trunk encapsulation dot1q on both interfaces. Check interfaces for config with show interface gig1/48 switchport and post results.


Sent from Cisco Technical Support Android App

New Member

Re:Trunking help

Looks like your tagging traffic and only have dot1q on one side of the trunk. As Panos mentioned, please configure on both sides and post results.

New Member

Re:Trunking help

Tagging is set up on both sides on the trunk:

Switch#show int gi1/48 switchport
Name: Gi1/48
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

show CDP Neighbours shows nothing

VTP domain and configuration is at same version with the 3750 set as server the the 4507 set as client.

New Member

Trunking help

You seem to be lacking on layer 2.

can you please confirm the output of "sho vlans" and "sho int trunk" ?

New Member

Re:Trunking help

4507:

Show vlan -

21   Native                           active

Show Int Trunk: -

show int trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/48      on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/48      1-4094

Port        Vlans allowed and active in management domain
Gi1/48      1,21

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/48      1,21

3750

Show vlan: -

21   Native                           active    Gi2/0/7

Show Int Trunk: -

brighton_3750_core#show int trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/23    on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/23    1-4094

Port        Vlans allowed and active in management domain
Gi1/0/23    1-2,4-7,21,32,49,65

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/23    1-2,4-7,21,32,49,65

New Member

Trunking help

and one more :

sho ip int br

New Member

Re:Trunking help

3750:

Vlan21                 10.50.0.129     YES manual up                    up

4507:

Vlan21                 10.50.0.131     YES NVRAM  up                    up

Re: Trunking help

Hi Matt

I would start again from scratch.

Reset the config on both ports (unplug the cable from one end first)

#default interface GigabitEthernet2/0/24

#default interface GigabitEthernet1/48

This will reset the config on both ports back to default, i.e nothing.

Then do the following:

interface GigabitEthernet2/0/24

description Server Core LINK

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk alllowed vlan 21

interface GigabitEthernet1/48

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 21

end

You should then be able to access your new core switch from the 3750. Also make sure, Vlan 21 actually exists on the new core switch as a L2 Vlan and the SVI is not shut down.

Thanks

Re: Trunking help

Hello,

1- try to apply below  simple command to allow vlans to have a traffic thorugh the trunk linmk:

    yourdevice(config-if)#switchport trunk allow vlan X,Y,Z        ..............  apply this command on both trunk interfaces from both devices.

2- for the MLS cisco devices some times you need to apply below command to provide the traffic between different vlans;

  # ip routing

- according to the  show output the native vlan from both ends still vlan 1 and not vlan 21.

regards,

New Member

Re:Trunking help

I have allowed specific VLANs on both trunk interfaces and confirmed that ip routing is enabled on both devices.

Still having the same issue

Thanks

Matt

Re: Trunking help

Hi,

correct, you allowed the vlans but still vlan 1 is the native vlan from both devices.

can you check this again plerase?

regards,

New Member

Re:Trunking help

Both sides have been set to native VLAN 21 to test. Still the same result

Re: Trunking help

check the native vlan by apllying command show int trunk

and this time try to configure a dynamic routing protocol.

router eigrp 65010

net x.x.x.x

net x.x.x.x

no auto-summary

New Member

Trunking help

Hi Hardi,

This has nothing to do with routing - they are on same vlan and same subnet.

The only lack is they are missing L2 connectivity.

Dear Matt,

Can you check if the switches have CDP enabled, is there some mac-address being cached (sho mac-address) ?

Re: Trunking help

Hi parvesh,

I think he has more than 2 vlans in each  devie, so I suggested to configure dynamic routing.

Hi Matt,

here some new steps:

1- apply the trunk configuration on a differet interface and from  both ends.

2- enable CDP on both devices.

3- use a different media UTP cable in this interconnection.

New Member

Re:Trunking help

Ok as suggested by devils advocate I have started again with the trunk config...

I have now also changed interfaces on both the 3750 and the 4507

CDP is enabled on both by going to config t - cdp run

I have also changed the cable

I am still getting nothing in CDP neighbours and cannot ping each side of the trunk.

I have logged a call with Cisco TAC via my SmartNet contract as well now.

This config should have been really simple!

Purple

Re: Trunking help

   If you don't have cdp neighbors then that's a physical issue unless cdp has been turned off .  If you want  to try again on each side try.   If it doesn't come up check logs for error .  Before anything else plug the devices together and you could just make the ports access ports in vlan 21 and it should ping across .  Both sides must show connected and you should see cdp . If not your you might have an issue with your cables .

vtp domain XXXX   (must match)

interface x/x

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan  21

switchport mode dynamic desirable

In this case native vlan is 1 because none is specified.

New Member

Trunking help

Even in case there are multiple vlans, it should work if both trunk interfaces carry the vlans.

Matti, share the complete config and interestingly the output from - sho mac-address.

Trunking help

Agreed, we need to see complete configs as something doesnt add up

Re: Trunking help

Hi Matt,

did you checked the local time on both siwtches? should in the same configuration.

New Member

Re:Trunking help

I wish I could post the configs but it is a secure environment so I can't. I have changed the physical cable, ports in both devices and still can't see anything on CDP neighbors which suggests that something else is going on! I will see what the TAC say but will post any feedback I get from them here in case it helps anyone else

Re: Trunking help

Hi Matt,

try to connect the two switches through two access ports and from the two end, have a check if you have any traffic between the connected ports.

the connected ports and from the two devices have to assign to the same vlan.

New Member

Trunking help

Hi,

can you check all your security configuration like running services, access lists, port security etc. and make sure that they don't affect the communications.

If you can backup your running configurations and just for a test reset to factory default and then try to connect both switches.

New Member

Re:Trunking help

I have to agree with Hardi that something is off here. Your original post showed your port configurations with the 'switchport trunk native vlan 21' command present however the ouput you posted for 'show int trunk' showed VLAN 1 as the native.

Try setting both switches to VTP transparent mode and see what happens.

414
Views
77
Helpful
25
Replies
CreatePlease to create content